SAP2000®

Integrated
Finite Elements Analysis
and
Design of Structures

SAP2000 Web Tutorial 1

DETAILED TUTORIAL INCLUDING
PUSHOVER ANALYSIS
COPYRIGHT

The computer program SAP2000 and all associated documentation are proprietary and copyrighted products. Worldwide rights of ownership rest with Computers and Structures, Inc. Unlicensed use of the program or reproduction of the documentation in any form, without prior written authorization from Computers and Structures, Inc., is explicitly prohibited.

Further information may be obtained from:

Computers and Structures, Inc
1995 University Avenue
Berkeley, California 94704 USA

tel: (510) 845-2177
fax: (510) 845-4096
e-mail: support@csiberkeley.com
web: www.csiberkeley.com
DISCLAIMER


THE USER MUST EXPLICITLY UNDERSTAND THE ASSUMPTIONS OF THE PROGRAM AND MUST INDEPENDENTLY VERIFY THE RESULTS.
# Table Of Contents

A. Introduction ............................................................................................................................................. 1

B. Description of Building Model ........................................................................................................... 3

C. Tutorial Part 1 - Creating, Analyzing and Designing the Basic Model ........................................ 8
   1a. Setting up the model geometry starting from a template ................................................................. 8
   1b. Setting up the model geometry starting from scratch, including restraints ................................... 18
   2. Relabeling joint, frame and shell elements ....................................................................................... 28
   3. Defining material properties ............................................................................................................. 30
   4. Defining frame sections ................................................................................................................... 32
   5. Defining shell sections .................................................................................................................... 34
   6. Assigning groups ............................................................................................................................. 35
   7. Assigning frame sections ................................................................................................................ 41
   8. Assigning shell sections ................................................................................................................... 47
   9. Assigning frame end releases ........................................................................................................ 48
  10. Defining static load cases ............................................................................................................... 51
  11. Assigning frame static loads ......................................................................................................... 53
  12. Assigning shell static loads .......................................................................................................... 61
  13. Assigning joint static loads .......................................................................................................... 63
  14. Assigning joint masses .................................................................................................................. 67
  15. Assigning diaphragm constraints .................................................................................................. 70
  16. Static and dynamic analysis (not pushover) .................................................................................. 71
  17. Reviewing mode shapes .............................................................................................................. 74
  18. Reviewing deformed shapes .......................................................................................................... 75
  19. Reviewing element forces and stresses ....................................................................................... 77
  20. Performing a steel design stress check .......................................................................................... 81

D. Tutorial Part 2 - Pushover Analysis ................................................................................................. 86
   1. Defining hinge properties (pushover) ............................................................................................ 86
   2. Assigning hinge properties (pushover) ....................................................................................... 90
   3. Viewing generated hinge properties (pushover) ......................................................................... 94
   4. Defining static pushover cases ..................................................................................................... 98
   5. Running the pushover analysis .................................................................................................. 105
   6. Displaying the pushover deformed shape and the sequence of hinge formation ....................... 106
   7. Displaying frame element forces at each step of the pushover ................................................... 110
   8. Displaying the pushover and capacity spectrum curves ............................................................. 112

E. Final Comments .................................................................................................................................. 123
A. Introduction

This tutorial is quite detailed. It is intended to introduce and demonstrate many of the capabilities of SAP2000. Because we are trying to demonstrate as many different capabilities as reasonable, the example problem is not necessarily created and the results are not necessarily reviewed in the most efficient and expedient manner. Often with computer programs, what is efficient for one person may not be the best method for the next person. It is assumed that once introduced to the SAP2000 capabilities and methods in this tutorial, users will decide which methods work best for them in their particular circumstances. Following is an outline of this tutorial (see the Table of Contents for a more complete outline):

A. Introduction

B. Description of Building Model

C. Tutorial Part 1 - Creating and Analyzing the Basic Model

D. Tutorial Part 2 - Pushover Analysis

E. Discussion of Additional Pushover Cases

If you are not interested in the pushover portion of the tutorial, you can skip parts D and E.

If you are only interested in the pushover tutorial, then you can read parts A and B, skip part C, and then open the already created model (without the pushover data) named Sapwb01c.sdb, which is supplied with this tutorial, and start with Step D.

Note: You must have SAP2000 Version 6.20 or later to read files Sapwb01c.sdb and Sapwb01d.sdb. These files are not compatible with earlier versions of SAP2000.

Finally, if you are not interested in working through the tutorial at this time, but want to see the results of the pushover analysis, then you can read parts A and B, skip part C and the first five steps of part D, and then open the already created model (with the pushover data) named Sapwb01d.sdb, which is supplied with this tutorial. You should then run the linear static and dynamic analysis by clicking Run on the Analyze menu. Next select Run Static Pushover from the Analysis menu to perform the pushover analysis. The results are now ready for viewing. See steps 6, 7 and 8 in part D for information on viewing results. See part E for additional discussion of results. Note that for real problems (as contrasted with tutorial problems) you should always run and review the results of a basic static analysis (and maybe also dynamic analysis, at least for mode shapes) to verify that your model is behaving as you intend.

SAP2000 has extensive online help that can help answer many of your questions. One of the most useful ways to access the online help is to press the F1 key on the keyboard from within most dialog boxes. Pressing the F1 key will bring up context sensitive help pertaining to the
dialog box that is open. You may find it useful to use this option throughout this tutorial to get more information.

If you require further technical assistance concerning this tutorial, or other aspects of SAP2000, you can contact CSI by phone at (510) 845-2177, or by e-mail at support@csiberkeley.com.
B. Description of Building Model

The example problem for this tutorial is a steel-frame building two bays wide by two bays deep, and two stories high. The plans and elevation in Figure B-1 show the basic dimensions and member sizes for the model. The building has a moment frame lateral force-resisting system in the X-direction and a braced frame lateral force-resisting system in the Y-direction. All steel is $F_y = 36$ ksi. The second floor is concrete over metal deck, and is assumed to be a rigid diaphragm in the model. The roof deck has no concrete, so it is not modeled as rigid.

Note: All column bases are pinned.

Figure B-1: Example Building Plans and Braced Frame Elevation
Figure B-2 shows perspective views of the computer model that include joint labels and frame element labels. Figure B-3 includes plan views of the computer model with frame element labels. Note that the infill beams are not specifically included in the computer model. These figures may be useful for reference when you are working through the tutorial.

**Perspective View Showing Joint Labels**

**Perspective View Showing Frame Element Labels**

Figure B-2: Views of Computer Model Showing Joint and Frame Element Labels
Figure B-3: Plan Views of Computer Model Showing Frame Element Labels
The following assumptions are used for dead and live loads:

Roof:  
DL = 40 psf  
LL = 20 psf  

Second Floor:  
DL = 80 psf  
LL = 50 psf  

Perimeter Wall:  
DL = 20 psf  

These loads are assumed to include the self-weight of the structural elements. Figure B-4 shows the beam span loads that are applied to each beam in the SAP2000 model.

---

**Figure B-4: Beam Span Loads Used In SAP2000 Model**
For this model, all mass is input at the joints. Table B-1 defines the joint masses used in the model. The bottom portion of the table defines the masses, the top portion of the table defines which joints are referred to as the center, corner and edge joints. Note that no mass is assigned to joints 22 and 26 at the roof level. These are the joints at the top of the chevron braces.

### Joint Labels at Center, Edge and Corner Joints

<table>
<thead>
<tr>
<th>Level</th>
<th>Center Joint</th>
<th>Edge Joints</th>
<th>Corner Joints</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roof</td>
<td>24</td>
<td>20, 23, 25, 28</td>
<td>19, 21, 27, 29</td>
</tr>
<tr>
<td>Second</td>
<td>14</td>
<td>11, 13, 15, 17</td>
<td>10, 12, 16, 18</td>
</tr>
</tbody>
</table>

### Joint Masses at Center, Edge and Corner Joints (k-sec² / ft)

<table>
<thead>
<tr>
<th>Level</th>
<th>Center Joint</th>
<th>Edge Joints</th>
<th>Corner Joints</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roof</td>
<td>0.72</td>
<td>0.48</td>
<td>0.30</td>
</tr>
<tr>
<td>Second</td>
<td>1.45</td>
<td>0.90</td>
<td>0.55</td>
</tr>
</tbody>
</table>

**Table B-1: Joint Masses Used In Computer Model**

The lateral earthquake loads are assumed to be 17 kips (0.0074ksf) at the roof level and 16 kips at the second level for the X-direction (moment frame direction), and 26 kips (0.0113 ksf) at the roof level and 23 kips at the second level for the Y-direction (braced frame direction). These forces are assigned as shell static uniform loads at the roof level and as joint loads at the second level. The second level forces are broken down into joint loads as shown in Table B-2.

### Joint Loads at Center, Edge and Corner Joints (k) For Second Level

<table>
<thead>
<tr>
<th>Earthquake Direction</th>
<th>Center Joint</th>
<th>Edge Joints</th>
<th>Corner Joints</th>
</tr>
</thead>
<tbody>
<tr>
<td>EQX</td>
<td>2.67</td>
<td>2.00</td>
<td>1.33</td>
</tr>
<tr>
<td>EQY</td>
<td>3.83</td>
<td>2.88</td>
<td>1.92</td>
</tr>
</tbody>
</table>

**Table B-2: Joint Forces Used In Computer Model For Static Earthquake Loading At Second Floor Level In X and Y Direction**
C. Tutorial Part 1 - Creating, Analyzing and Designing the Basic Model

This tutorial steps through setting up the model geometry both from a built-in template (step 1a), and from scratch (step 1b). It is not necessary to do both of these steps, in order to complete the tutorial; one or the other is sufficient. However, it may be helpful to see the process and techniques used in completing both steps. We recommend that to obtain additional information during the course of this tutorial you refer liberally to the online help available in SAP2000 by pressing the F1 key from within almost any dialog box to obtain context-sensitive help.

Step 1a: Setting Up the Model Geometry From a Template

1. Click the drop down box in the status bar to change the units to kip-ft.

2. From the File menu select New Model from Template…. This displays the Model Templates dialog box.

3. In this dialog box:
   - Click on the Space Frame template. This will display the Space Frame dialog box (see Figure C-1).

![Figure C-1: Space Frame Dialog Box](image)

   - In this dialog box:
     - Change the Number of Bays along X to 2.
 ✓ Check the Restraints box if it is not already checked.
 ✓ Check the Gridlines box if it is not already checked.
 ✓ Accept the remainder of the default values.
 ✓ Click the OK button.

4. The screen will refresh and display a 3-D and a 2-D (XY Plane @ Z=24) view of the model in vertically tiled adjoining windows.

5. Note that the default restraints provided when the Restraints box is checked in the Space Frame dialog box are pinned supports.

6. Click in the window labeled X-Y Plane @ Z=24 to make sure it is active. Note when the window is active, its title bar will be highlighted.

7. Click the **yz 2D View** button on the main toolbar to change the view to an elevation in the YZ plane. Note that the title of the window reads YZ Plane @ X=24. This same title also occurs on the left-hand side of the status bar at the bottom of the SAP2000 window.

8. Click the roof level beam on the left side of the elevation to select it. From the **Edit** menu, click **Divide Frames...** to display the Divide Selected Frames dialog box.
9. Accept the default values in this dialog box and click the **OK** button. The roof beam is divided into two beams, thus providing a node for the top of the chevron brace.

10. Click the **Draw Frame Element** button on the side toolbar, or select **Draw Frame Element** from the **Draw** menu. The program is now in Draw Mode.

   *Note: If you hold the pointer over a toolbar button for a few seconds, a text box including the name of the button will appear.*

11. Make sure that the **Snap to Joints and Grid Points** button on the side toolbar is depressed. Place the mouse pointer on the joint labeled “A” in Figure C-3 and click on the left mouse button. Note that when the mouse pointer is near the joint, it snaps to the joint, and a text box that says “Grid Intersection” appears. This is the effect of the **Snap to Joints and Grid Points** feature.

   *Note: Other snap options included in SAP2000 include Snap to Midpoints and Ends, Snap to Element Intersections, Snap to Perpendicular, and Snap to Lines and Edges. The buttons for these features are located on the side toolbar just below the **Snap to Joints and Grid Points** button. Note that all of the snap features can also be accessed through the **Snap To** option on the **Draw** menu. For more information on the snap capabilities of SAP2000, refer to the topic titled Snap Tools in the SAP2000 online help. Click on the **Help** menu and select the **Search for Help on** option to access the online help in SAP2000.*

---

![Figure C-3: Joint Labels For Drawing Chevron Brace](image-url)
12. Place the mouse pointer near the joint labeled “B” in Figure C-3 and note that in this case the Snap To option text box just says “Point” because the joint does not occur at a grid intersection. Click on the left mouse button to draw the chevron brace element.

Note: If you wanted to, at this point you could just click on point C in Figure C-3 to draw the second brace element. If we were to do that, the start point for the brace would be at the top (point B) and the bottom point would be at the bottom (point C). Though not necessarily a problem, this would be inconsistent with how we input the first brace. In this example we will opt for consistency.

Note: If you wanted to, at this point you could move the mouse pointer into the 3D View window, and select the second joint for the next frame element there. Try moving the mouse pointer over the 3D View window, but for this example don’t actually click to define the second frame member.

13. Press the Enter key on the keyboard to stop drawing the second frame member. Note that the Draw Frame Element button is still depressed, i.e., the program is still in Draw Mode and ready to draw another frame element.

14. Click on the joint labeled “C” and then the joint labeled “B” in Figure C-3, and then press the Enter key on the keyboard to draw the second chevron brace member.

15. Click the Quick Draw Frame Element button on the side toolbar. Then click in the area labeled “D” in Figure C-3 to enter the X-braces. The model now appears as shown in Figure C-4.

Note: The X-braces could also have been entered using the same technique that was employed for the chevron braces.

Note: Both the Draw Frame Element and the Quick Draw Frame Element options are also available on the Draw menu.

Note: The Quick Draw Frame Element option works two different ways. You can click on a grid segment to quickly draw a single frame element between the two adjacent perpendicular grid lines. Alternatively, you can click in a space bounded by four grid lines to quickly draw a cross brace as was done here.

16. Click the Down One Gridline button on the main toolbar twice to display the YZ elevation at X=-24. Note the window title changes to Y-Z Plane @ X=-24. The model appears as shown in Figure C-5.

17. We will use a different method to locate these chevron braces. Click the Snap to Midpoints and Ends button to activate this snapping option. Click the Draw Frame Element button on the side toolbar, or select Draw Frame Element from the Draw menu. The program is now in Draw Mode.
Figure C-4: Model After Inputting First Set of Braces

Figure C-5: Model Ready To Draw Second Set of Braces
18. Place the mouse pointer on the joint labeled “A” in Figure C-5 and click on the left mouse button.

19. Move the mouse pointer over to the center of the beam element at the point labeled “B” in Figure C-5. When the Snap To feature text box appears saying “Midpoint” click the left mouse button to input the brace element. Then press the Enter key on the keyboard.

20. Click the Snap to Midpoints and Ends button to deactivate this snapping option.

21. Click on the joint labeled “C” and then the joint labeled “B” in Figure C-5, and then press the Enter key on the keyboard to draw the second chevron brace member.

22. Click the Quick Draw Frame Element button on the side toolbar. Then click in the area labeled “D” in Figure C-5 to enter the X-braces.

23. Click the Pointer button to exit Draw Mode and enter Select Mode.

24. Click the roof beam at the top of the braced frame to select it. Also click the joint at the top of the chevron brace (center of braced frame roof beam) to select it.

25. From the Edit menu select Divide Frames... to display the Divide Selected Frames dialog box.

26. In this dialog box:
   - Select the Break At Intersections With Selected Frames and Joints option.
   - Click the OK button.

   Note: This completes inputting of the frame element geometry. Now we will input shell element geometry. We will use shell elements to model the roof diaphragm. We will demonstrate three different options for inputting the shell elements.

27. Click the xy 2D View button on the main toolbar to change the view to a plan in the XY plane. Note that the title of the window reads XY Plane @ Z=24.

28. Click the Quick Draw Rectangular Shell Element button on the side toolbar (or select Quick Draw Rectangular Shell Element from the Draw menu).

29. Click in the area labeled “A” in Figure C-6 to input the first shell element. Note that a quick Shell element is drawn by clicking in a grid space, bounded by four grid lines.

30. Note that just the outline of the shell element is shown. Sometimes when working with shell elements it is easier if you can view the shell element filled in. Click the Set Elements
button on the main toolbar (or select Set Elements... from the View menu). This displays the Set Elements Dialog box.

31. Check the box labeled Fill Elements and click the OK button to display the shell elements filled.

32. Click in the area labeled “B” in Figure C-6 to input a second shell element. Note that this element will be reshaped in a subsequent step.

33. Click the Draw Rectangular Shell Element button on the side toolbar (or select Draw Rectangular Shell Element from the Draw menu). Make sure that the Snap to Joints and Grid Points button on the side tool bar is selected (depressed).

![Figure C-6: Shell Element Input](image)

34. Click on the point labeled “C” in Figure C-6 and then click the point labeled “D” to input the next shell element. Note that a rectangular Shell element is drawn by clicking to define two corners that are diagonally opposite of each other.

35. Click the Draw Quadrilateral Shell Element button on the side toolbar (or select Draw Quad Shell Element from the Draw menu).

36. Click on the points labeled “E”, “F”, “G” and “H” in Figure C-6, in that order, to draw a quadrilateral shell element.
37. Click on the points labeled “H”, “G”, “C” and “H” in Figure C-6, in that order, to draw a triangular shell element.

*Note: Shell elements may be either four-sided, or three-sided. In general, four-sided elements are recommended.*

38. Click the **Reshaper** button on the side toolbar (or select **Reshape Element** from the **Draw** menu).

39. Click once on the shell element in the lower right-hand corner (drawn in item 29 in the area labeled “B” in Figure C-6) to highlight it. Note that member end handles appear on the shell element as shown in Figure C-7.

![Figure C-7: Reshape Shell Element](image)

40. Click on the point labeled “A” in Figure C-7, and while holding down the left mouse button, drag the member end handle to point “B”.

41. Click the **Refresh Window** button on the main toolbar (or select **Refresh Window** from the **View** menu) to see the results of reshaping the element.

42. Click the **Draw Quadrilateral Shell Element** button on the side toolbar (or select **Draw Quad Shell Element** from the **Draw** menu). Then click on the points labeled “C”, “A”, “B” and “C” in Figure C-7, in that order, to draw a triangular shell element.

43. Click the **Pointer** button to exit Draw Mode and enter Select Mode.
44. Now we will return the shell element view to unfilled elements. Click the **Set Elements** button on the main toolbar (or select **Set Elements** from the **View** menu). This displays the Set Elements Dialog box.

45. Uncheck the box labeled Fill Elements and click the **OK** button to display the shell elements not filled. The display should appear as shown in Figure C-8.

![Figure C-8: Model With All Geometry Input](image)

46. From the **File** menu choose **Save** and input a new name to save your file.

*Note: It is a good idea to save your file often.*

This completes the input of the model geometry. Now you can do one of the following:

- If you started the model from a template, and do not want to try starting the model from scratch, then skip to Step 2.
- If you started the model from a template and now want to try starting it from scratch, then continue on to Step 1b.
- If you started the model from scratch, and do not want to try starting the model from a template, then skip to Step 2.
If you started the model from scratch, and now want to try starting it from a template, then return to the beginning of Step 1a.

If you want to stop working on the tutorial for now, and close SAP2000, make sure that you have saved your file as outlined in item 46, and then from the **File** menu select **Exit**.
Step 1b: Setting Up the Model Geometry From Scratch

This tutorial steps through setting up the model geometry both from a built-in template (step 1a), and from scratch (step 1b). It is not necessary to do both of these steps in order to complete the tutorial; one or the other is sufficient. However, each of them has some unique information.

1. Click the drop down box in the status bar to change the units to kip-ft.

2. From the File menu select New Model…. This displays the Coordinate System Definition dialog box.

3. In this dialog box:
   - Select the Cartesian tab.
   - Set the Number of Grid Spaces in X direction to 2.
   - Set the Number of Grid Spaces in Y direction to 4.
   - Set the Number of Grid Spaces in Z direction to 2.
   - Set the Grid Spacing in the X direction to 24.
   - Set the Grid Spacing in the Y direction to 12.
   - Set the Grid Spacing in the Z direction to 12.
   - Click the OK button to accept the grid definition.

4. The screen will refresh and display a 3-D and a 2-D (XY Plane @ Z=24) view in vertically-tiled adjoining windows.

5. Click in the window labeled X-Y Plane @ Z=24 to make sure it is active. Note when the window is active, its title bar will be highlighted.

6. Click the Quick Draw Frame Element button on the side toolbar (or select Quick Draw Frame Element from the Frame menu).

   Note: If you hold the pointer over a toolbar button for a few seconds, a text box including the name of the button will appear.

7. In the window labeled X-Y Plane @ Z=24, to enter a beam element click on a grid line. The Quick Draw Frame Element tool will then create a beam element on that grid line spanning between the closest perpendicular grid lines on either side of the point where you clicked.
Thus click the ten locations designated by an O in Figure C-9 to draw some of the roof level beams.

Figure C-9: Quick Drawing Roof Level Beams

Figure C-10: Drawing Remaining Roof Level Beams
Note: If you miss slightly when clicking on a grid line, the program may assume you were attempting to input two diagonal braces in the bay bounded by the grid lines. If this happens, simply click the Undo button on the main toolbar twice, or select Undo Frame Add from the Edit menu twice.

8. Click the Draw Frame Element button on the side toolbar. The program is now in Draw Mode.

9. Make sure that the Snap to Joints and Grid Points button on the side tool bar is depressed. Place the mouse pointer on the joint labeled “A” in Figure C-10 and click on the left mouse button. Note that when the mouse pointer is near the joint, it snaps to the joint, and a text box that says “Grid Intersection” appears. This is the effect of the Snap to Joints and Grid Points feature.

Note: Other snap options included in SAP2000 include Snap to Midpoints and Ends, Snap to Element Intersections, Snap to Perpendicular, and Snap to Lines and Edges. The buttons for these features are located on the side toolbar just below the Snap to Joints and Grid Points button. Note that all of the snap features can also be accessed through the Snap To… option on the Draw menu. For more information on the snap capabilities of SAP2000, refer to the topic titled Snap Tools in the SAP2000 online help. Click on the Help menu and select the Search for Help on… option to access the SAP2000 online help.

10. Place the mouse pointer near the joint labeled “B” in Figure C-10 and Click on the left mouse button to draw the roof beam element.

Note: We couldn’t use the Quick Draw Frame Element tool to draw this beam because the beam crosses a grid line.

11. By default the program is now ready to draw another frame element starting from point “B”. Press the Enter key on the keyboard to stop from drawing the second frame member at this location.

12. Place the mouse pointer on the joint labeled “C” in Figure C-10 and click on the left mouse button. Click in sequence on joints “D” and “E” and then press the Enter key to draw the next two roof beams.

13. We will now edit the grid lines so that we can use the Quick Draw Frame Element tool to enter the last roof beam that will span from point “F” to point “G” in Figure C-10.

14. From the Draw menu select Edit Grid…. This displays the Modify Grid Lines dialog box.

15. In this dialog box:
   - Click the Y option in the Direction area.
- Highlight -12 in the Y Location list box and click the **Delete Grid Line** button.
- Highlight 12 in the Y Location list box and click the **Delete Grid Line** button.
- Click the **OK** button.

16. Click the **Quick Draw Frame Element** button on the side toolbar (or select **Quick Draw Frame Element** from the **Frame** menu).

17. Click on the grid line between points “F” and “G” in Figure C-10 to enter the last roof beam. The model now appears as shown in Figure C-11.

![Figure C-11: Model After All Roof Level Beams Have Been Drawn](image)

18. Select all of the roof level frame elements and joints in the X-Y Plane @ Z=24 by “windowing.” To do this:

   - Click the **Pointer** button on the side toolbar to activate the Select Mode.
   - Move the pointer above and to the left of the frame elements and joints.
   - Click and hold the left mouse button.
   - While holding, move the pointer below and to the right of the frame elements and joints. A “rubber-band” window will show the region selected.
- Release the left mouse button to select all elements in this window.

19. From the **Edit** menu, choose **Copy**.

20. From the **Edit** menu, choose **Paste**. This will display the Paste Coordinates dialog box.

21. In this dialog box input 0 for Delta X, 0 for Delta Y and -12 for Delta Z.

22. Click the **OK** button and the geometry for the roof level is copied to the second level.

23. Click the **Down One Gridline** button on the main toolbar to display the plan view at the second floor level, Z=12. Note the window title changes to X-Y Plane @ Z=12. The model now appears as shown in Figure C-12.

**Figure C-12: Model After All Roof Level Beams Copied To Second Level**

*Note: The second level beams at the braced frames do not need a joint at the center to receive a brace. Thus we will delete the center joints.*

24. Click the second level beams labeled “A” and “B” in Figure C-12 to select them.

25. From the **Edit** menu select **Join Frames** to combine these two elements into a single element and remove unused joints left over from the joining process.
26. Click anywhere on the combined frame member to select it. Note that the entire member is highlighted thus verifying that the members have been joined.

27. Click the Clear Selection button on the side toolbar (or select Clear Selection from the Select menu) to deselect the beam.

28. Click the second level beams labeled “C” and “D” in Figure C-12 to select them. From the Edit menu select Join Frames to combine these two elements into a single element.

29. Click in the window labeled X-Y Plane @ Z=12 to make sure it is active. Note when the window is active, its title bar will be highlighted.

30. Click the yz 2D View button on the main toolbar to change the view to an elevation in the YZ plane. Note that the title of the window reads YZ Plane @ X=24. This same title also occurs on the left-hand side of the status bar at the bottom of the SAP2000 window. The model appears as shown in Figure C-13.

![Figure C-13: Y-Z Elevation](image)

31. Click the Draw Frame Element button on the side toolbar. The program is now in Draw Mode.

32. Make sure that the Snap to Joints and Grid Points button on the side tool bar is depressed. Place the mouse pointer on the joint labeled “A” in Figure C-13 and click on the left mouse button. Note that when the mouse pointer is near the joint, it snaps to the joint,
and a text box that says “Grid Intersection” appears. This is the effect of the Snap to Joints and Grid Points feature.

33. Place the mouse pointer near the joint labeled “B” in Figure C-13 and note that in this case the Snap To option text box just says “Point” because the joint does not occur at a grid intersection. Click on the left mouse button to draw the chevron brace element.

**Note:** If you wanted to, at this point you could just click on point C in Figure C-12 to draw the second brace element. If we were to do that, the start point for the brace would be at the top (point B) and the bottom point would be at the bottom (point C). Though not necessarily a problem, this would be inconsistent with how we input the first brace. In this example we will opt for consistency.

**Note:** If you wanted to, at this point you could move the mouse pointer into the 3D View window, and select the second joint for the next frame element. Try moving the mouse pointer over the 3D View window, but for this example don’t actually click to define the second frame member.

34. Press the Enter key on the keyboard to stop drawing the second frame member. Note that the **Draw Frame Element** button is still depressed, i.e., the program is still in Draw Mode and ready to draw another frame element.

35. Click on the joint labeled “C” and then the joint labeled “B” in Figure C-13, and then press the Enter key on the keyboard to draw the second chevron brace member.

36. Click the **Quick Draw Frame Element** button on the side toolbar. Then click in the area labeled “D” in Figure C-13 to enter the X-braces.

**Note:** The **Quick Draw Frame Element** option works two different ways. You can click on a grid segment to quickly draw a quick single frame element between the two adjacent perpendicular grid lines. Alternatively, you can click in a space bounded by four grid lines to draw a cross brace as was done here.

**Note:** The X-braces could also have been entered using the same technique that was employed for the chevron braces.

**Note:** Both the **Draw Frame Element** and the **Quick Draw Frame Element** options are also available on the **Draw** menu.

37. Click the **Down One Gridline** button on the main toolbar twice to display the elevation view at X=-24. Note the window title changes to Y-Z Plane @ X=-24.

38. Repeat steps 32 through 36 to draw the second set of braces. Note that the second set of braces occurs on the right-hand side of the elevation. The model now appears as shown in Figure C-14.
39. Now we will draw the columns. Click the six column grid line locations designated with an O in Figure C-14 to define the first line of columns.

40. Click the Pointer button to exit Draw Mode and enter Select Mode. Click on the six columns just entered to select them.

   Note: A message on the left-hand side of the status bar at the bottom of the SAP2000 window tells you how many of each type of element are currently selected.

41. From the Edit menu, choose Replicate. This will display the Replicate dialog box.

42. In this dialog box select the Linear tab, input 24 for X, 0 for Y and 0 for Z. Input 2 for the number.

43. Click the OK button and the geometry for the columns will be replicated twice at a 24-foot spacing.

   Note: In addition to linear replication, the Replicate option also allows radial replication and mirroring. Refer to the topic replicate in the online help for more information. The online help can be accessed by clicking on the Help menu and selecting the Search for Help on… option or you can access it by pressing the F1 key on the keyboard when the Replicate dialog box is open.
44. Now we will apply the base restraints. Click in the window labeled Y-Z Plane @ X=-24 to make sure it is active. Note when the window is active, its title bar will be highlighted.

45. From the View menu select Set 2D View…. This will display the Set 2D View dialog box.

46. Make sure the X-Y plane option button is selected and enter 0 in the Z = edit box.

47. Click the OK button, and the window will now display the X-Y Plane @ Z=0.

48. Select all of the joints in the X-Y Plane @ Z=0 by “windowing.” To do this:
   - Click the Pointer button on the side toolbar left side of the screen.
   - Move the pointer above and to the left of the support joints.
   - Click and hold the left mouse button.
   - While holding, move the pointer below and to the right of the support joints. A “rubber-band” window will show the region selected.
   - Release the left mouse button to select all elements (joints) in this window.

49. From the Assign menu, choose Joint, and then Restraints…from the submenu. This will display the Joint Restraints dialog box.

50. In this dialog box:
   - Click the pinned base fast restraint button to set all translational degrees of freedom (U1, U2 and U3) as restrained.
   - Click the OK button

51. Click in the window labeled 3-D View to make sure it is active.

52. Click the Refresh Window button on the main toolbar (or select Refresh Window from the View menu) to see the restraints in the 3-D View window.

53. Click in the plan view window currently labeled Joint Restraints to make sure it is active.

54. Click the Show Undeformed Shape button to reset the view and to return the window label to X-Y Plane @ Z=0.

55. Click the Up One Gridline button on the main toolbar twice to display the elevation view at Z=24.
56. To finish defining the model geometry, complete items 25 through 46 in Step 1a, i.e., the previous step. When finished, return to this point.

This completes the input of the model geometry from scratch. Now you can do one of the following:

- If you started the model from scratch, and do not want to try starting the model from a template, then go on to Step 2.
- If you started the model from scratch, and now want to try starting it from a template, then return to the beginning of Step 1a.
- If you want to stop working on the tutorial for now, and close SAP2000, make sure that you have saved your file as outlined in item 46 of Step 1a, and then from the File menu select **Exit**.
Step 2: Relabeling Joint, Frame and Shell Elements

1. Click in the window labeled 3-D View to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. Click the Set Elements button on the main toolbar (or select Set Elements… from the View menu). This displays the Set Elements Dialog box.

3. In this dialog box:
   - In the Joints area check the Labels box.
   - In the Frames area check the Labels box.
   - In the Shells area check the Labels box.
   - Click the OK button.

   Note: We are turning on the element labels so that we can see the effect of the element relabeling. It is not necessary to turn on element labels in order to relabel them.

4. From the Select menu choose Select, and then All from the submenu. All elements in the model (joints, frame elements and shell elements) are selected.

5. From the Edit menu choose Change Labels to display the Relabel Selected Items dialog box.

6. In this dialog box:
   - Press the F1 key to display the context-sensitive online help for this dialog box.
   - When finished reading the online help, click the “X” in the top right-hand corner of the Help window, or select Exit from the File menu on the Help window to close it.
   - In the Change Label Initialization area of the dialog box type 1 in the Next Number edit boxes for Joint, Frame and Shell elements.
• Accept the rest of the default values in the dialog box.

• Click the OK button to make the changes.

Note: It is not typically necessary to renumber the elements. It is done here to illustrate the process, and to make sure all tutorial users have the same numbering system, whether they started the model from a template, or from scratch, since we will refer to joint and frame elements by their labels later in this tutorial.

Note: Joint, Frame and Shell element labels can be given alphanumeric prefixes. These prefixes can be input in the Prefix edit boxes on the Relabel Selected Items dialog box.

Note: It is not necessary to select all elements to relabel. You could select only a few elements, of any type, and relabel only the selected elements.

7. Click the Set Elements button on the main toolbar (or select Set Elements… from the View menu). This displays the Set Elements Dialog box.

8. In this dialog box:

• In the Joints area uncheck the Labels box.

• In the Frames area uncheck the Labels box.

• In the Shells area uncheck the Labels box.

• Click the OK button.

9. Click the Save Model button on the main toolbar, or select Save from the File menu to save the file.

This completes relabeling the joint, frame and shell elements.
**Step 3: Defining Material Properties**

In this tutorial we will use default material properties, except that we will not use the self-weight and self mass. In this step we will first review the default material properties (items 1 through 14) and then we will change the material properties to set the self-weight and self mass to zero (items 15 through 21).

1. From the Define menu choose Materials…. This displays the Define Materials dialog box.

2. Highlight CONC in the Materials area and click the Modify/Show Material button. This will display the Material Property Data dialog box.

   *Note: To add a new material property, click the Add New Material button.*

3. Note the material properties shown, and notice that they are in units of kips and feet.

4. Click the Cancel button to exit the Material Property Data dialog box without making any changes.

5. Click the Cancel button to exit the Define Materials dialog box without making any changes.

6. Click the drop down box in the status bar to change the units to kip-in.

7. From the Define menu choose Materials…. This again displays the Define Materials dialog box.

8. Highlight CONC in the Materials area, if it is not already highlighted, and click the Modify/Show Material button. This displays the Material Property Data dialog box for the material named CONC.

9. Note the material properties shown, and notice that they are in units of kips and inches.

10. Click the Cancel button to exit the Define Materials dialog box without making any changes.

11. Highlight STEEL in the Materials area and click the Modify/Show Material button. This will display the Material Property Data dialog box.

12. Note the material properties shown, and notice that they are in units of kips and inches.

13. Click the Cancel button twice to exit the Material Property Data dialog box and the Define Materials dialog box without making any changes.

14. Click the drop down box in the status bar to change the units back to kip-ft.

15. From the Define menu choose Materials…. This displays the Define Materials dialog box.
16. Highlight CONC in the Materials area and click the **Modify/Show Material** button. This will display the Material Property Data dialog box.

17. In this dialog box:
   - In the Analysis Property Data area type **0** in the Mass Per Unit Volume edit box.
   - In the Analysis Property Data area type **0** in the Weight Per Unit Volume edit box.
   - Click the **OK** button.

18. Highlight STEEL in the Materials area and click the **Modify/Show Material** button. This will display the Material Property Data dialog box.

19. In this dialog box:
   - In the Analysis Property Data area type **0** in the Mass Per Unit Volume edit box.
   - In the Analysis Property Data area type **0** in the Weight Per Unit Volume edit box.
   - Click the **OK** button.

20. Click the **OK** button to close the Define Materials dialog box.

21. Click the **Save Model** button on the main toolbar, or select **Save** from the **File** menu to save the file.

This completes the review and definition of material properties.
Step 4: Defining Frame Sections

We will use nine different wide flange sections (W24X62, W24X55, W21X44, W18X40, W18X35, W16X26, W14X132, W8X58 and W8X31) and two different structural tube sections (TS5X5X1/4 and TS4X4X1/4) for this model. We will use the structural sections data file provided with SAP2000. The file is called SECTIONS.PRO and resides in the same directory as SAP2000.

1. From the Define menu choose Frame Sections…. This will display the Define Frame Sections dialog box.

2. In this dialog box:
   - Click on the Import drop-down box.
   - Click on Import I/Wide Flange. This will display the Section Property File dialog box.
   - In this dialog box:
     - Locate the SECTIONS.PRO data file. It is typically located in the directory where you installed SAP2000.
     - Open the SECTIONS.PRO data file by highlighting it and clicking on the Open button or by double clicking on the file name.
     - This will display a dialog box that includes a scrolling list box showing all the I/wide flange sections available in the data file. The title bar of this box displays the full path to the data file.

   Note: In a SAP2000 session you only have to locate and open the SECTIONS.PRO data file once. You have the option to select another data file at any time by choosing Preferences in the Options menu and selecting the Steel tab.

   - In the list box:
     - Use the Scroll buttons to locate the W24X62 frame section. Click once on this section to highlight it.
     - Use the Scroll buttons to locate the W24X55 frame section. While holding down the Ctrl key on the keyboard, click once on this section to highlight it and add it to the selection.
Note: Frame sections may be selected one at a time or they may be selected in groups as shown in this example. To select multiple frame sections that are next to each other, hold down the Shift key and click on the first and last frame element in the group. To select multiple frame sections that are not next to each other, hold down the Ctrl key and click each section you want to select, as is done here.

- Use the Scroll buttons to locate the W21X44, W18X40, W18X35, W16X26, W14X132, W8X58 and W8X31 frame sections. While holding down the Ctrl key on the keyboard, click once on each section to highlight it and add it to the selection.

- Click the OK button. This will display the I/Wide Flange Section dialog box which shows a schematic view of the last selected section (W8X31), section dimensions, and STEEL as the default material type.

- Click the OK button. This will close the I/Wide Flange Section dialog box and return to the Define Frame Sections dialog box. Notice that in the dialog box the labels of the selected frame elements are added to the default section name (FSEC1) in the Frame Section area.

- Click on the Import drop-down box.

- Click on Import Box/Tube. This will display a scrolling list box showing all the box/tube sections available in the data file.

- In this dialog box:
  - Use the Scroll buttons to locate the TS5X5X1/4 frame section. Click once on this section to highlight it.
  - Use the Scroll buttons to locate the TS4X4X1/4 frame section. While holding down the Ctrl key on the keyboard, click once on this section to highlight it and add it to the selection.
  - Click the OK button. This will display the Box/Tube Section dialog box that shows a schematic view of the last selected section (TS4X4X1/4), section dimensions, and STEEL as the default material type.

- Click the OK button. This will close the Box/Tube Section dialog box and return to the Define Frame Sections dialog box. Notice that in the dialog box the labels of the selected frame elements are added to the previously defined frame sections.

3. Click the OK button to close the Define Frame Sections dialog box.

This completes the definition of frame sections.
Step 5: Defining Shell Sections

We will use one shell section property in the model to model the roof diaphragm. We will assume the roof diaphragm to be equivalent to a 1" thick concrete diaphragm. This is not a recommended way to approximate a metal deck diaphragm, it is just a simple and expedient method to use for this example.

1. From the Define menu choose Shell Sections…. This will display the Define Shell Sections dialog box.

2. In this dialog box:
   - Click the Add New Section button. This will display the Shell Sections dialog box.
   - In this dialog box:
     - Type ROOF in the Section Name edit box.
     - Accept the default material CONC.
     - In the thickness area type 0.0833 in both the Membrane and Bending edit boxes.
     - In the Type area, select the Membrane option.
     
     Note: In general we recommend using the Shell type option for shell elements.

     - Click the OK button.

3. Click the OK button to close the Define Shell Sections dialog box.

4. Click the Save Model button on the main toolbar, or select Save from the File menu to save the file.

This completes the definition of shell sections.
Step 6: Assigning Groups

Groups can be a powerful tool for selecting elements for both assignments and display. In this step we will create nine groups, as shown in the table below:

<table>
<thead>
<tr>
<th>Group Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ROOF</td>
<td>All roof level joints, frame elements and shell elements</td>
</tr>
<tr>
<td>2ND</td>
<td>All second level joints, frame elements and shell elements</td>
</tr>
<tr>
<td>COLS</td>
<td>All column elements</td>
</tr>
<tr>
<td>FRCOLS</td>
<td>All moment frame columns</td>
</tr>
<tr>
<td>BRCOLS</td>
<td>All braced frame columns</td>
</tr>
<tr>
<td>BRACE1</td>
<td>All braces between the first and second level</td>
</tr>
<tr>
<td>BRACE2</td>
<td>All braces between the second level and the roof level</td>
</tr>
<tr>
<td>FRMGIRD</td>
<td>All moment frame girders</td>
</tr>
<tr>
<td>BASE</td>
<td>All bottom level columns and support joints</td>
</tr>
</tbody>
</table>

*Note: By default the program creates a group named ALL which includes all elements in the model (joint elements included).*

1. Click in the window labeled X-Y Plane @ Z=24 to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. Click the **Pointer** button on the side toolbar and select all of the elements in the X-Y Plane @ Z=24 by “windowing.”

   *Note: To add more joints and/or elements to an already assigned group, first select the group, then select more joints and/or elements, and finally assign them to the group. Group assignment always replaces the existing elements in that group.*

3. From the Assign menu choose **Group Name**. This will display the Assign Group dialog box.

4. In this dialog box:
   - Type **ROOF** in the edit box at the top of the Groups area.
   - Click the **Add New Group Name** button to define a group named ROOF.

      *Note: A common error is to forget to click the Add New Group Name button before pressing the OK button.*

   - Click the **OK** button to assign the selected elements to the group named ROOF.

5. Click the **Down One Gridline** button on the main toolbar to display the plan view at Z=12. Note the window title changes to X-Y Plane @ Z=12.
6. Select all of the elements in the X-Y Plane @ Z=12 by “windowing.”

7. From the Assign menu choose Group Name…. This will display the Assign Group dialog box.

8. In this dialog box:
   - Type 2ND in the edit box at the top of the Groups area.
   - Click the Add New Group Name button to define a group named 2ND.
   - Click the OK button to assign the selected elements to the group named 2ND.

9. Click on the xz button on the main toolbar to view an elevation in the X-Z plane. Note the title of the window is probably X-Z Plane @ Y=24; it depends on the sequence of steps you followed in creating the model. If the window title is not X-Z Plane @ Y=24, click the Up One Gridline button on the main toolbar or the Down One Gridline button on the main toolbar until the title of the window is X-Z Plane @ Y=24.

10. Click on the six column elements in this view to select them.

    Note: SAP2000 will display the number and type of elements you have selected on the left-hand side of the status bar at the bottom of the SAP2000 window.

    Note: You can click again on a single selected element to deselect it. If you want to deselect all elements at once, then click the Clear Selection button on the side toolbar, or choose Clear Selection from the Select menu.

11. Click the Down One Gridline button on the main toolbar to display the elevation at Y=0. Note the window title changes to X-Z Plane @ Y=0.

12. Select the bottom level columns by intersection. To do this:
   - Click the Pointer button on the side toolbar.
   - Click the Set Intersecting Line Select Mode button on the side toolbar.
   - Move the pointer to the left of the columns you want to select.
   - Click and hold the left mouse button.
   - While holding, move the pointer to the right of the members you want to select. A “rubber band” will show the intersecting line.
   - Release the left mouse button to select all members that intersect this line.
13. Click the Set Intersecting Line Select Mode button again and select the top level columns.

14. Click the Down One Gridline button on the main toolbar to display the elevation at Y=-24. Note the window title changes to X-Z Plane @ Y=-24.

15. Use the Intersecting Line mode to select the six column elements in this elevation. There should now be a total of 18 frame elements selected. You can confirm this by looking on the left-hand side of the status bar at the bottom of the SAP2000 window.

16. From the Assign menu choose Group Name…. This will display the Assign Group dialog box.

17. In this dialog box:
   - Type COLS in the edit box at the top of the Groups area.
   - Click the Add New Group Name button to define a group named COLS.
   - Click the OK button to assign the selected elements to the group named COLS.

18. Now we will assign the moment frame columns to a group. Click on the left-hand column and the center column (4 elements total) to select them.

19. Click the Up One Gridline button on the main toolbar twice to display the elevation at Y=24. Note the window title changes to X-Z Plane @ Y=24.

20. Click on the right-hand column and the center column (4 elements total) to select them. There should now be eight frame elements selected.

21. From the Assign menu choose Group Name…. This will display the Assign Group dialog box.

22. In this dialog box:
   - Type FRCOLS in the edit box at the top of the Groups area.
   - Click the Add New Group Name button to define a group named FRCOLS.
   - Click the OK button to assign the selected elements to the group named FRCOLS.

23. Now we will assign the braced frame columns to a group. Click on the yz button on the main toolbar to view an elevation in the Y-Z plane. If necessary, click the Up One Gridline button on the main toolbar until the title of the window is Y-Z Plane @ X=24.

24. Click on the four column elements at the braced frame to select them.
25. Click the **Down One Gridline** button on the main toolbar twice to display the elevation at X=-24.

26. Click on the four column elements at the braced frame to select them. There should now be eight frame elements selected.

27. From the **Assign** menu choose **Group Name**…. This will display the Assign Group dialog box.

28. In this dialog box:
   
   • Type **BRCOLS** in the edit box at the top of the Groups area.
   
   • Click the **Add New Group Name** button to define a group named BRCOLS.
   
   • Click the **OK** button to assign the selected elements to the group named BRCOLS.

29. Now we will assign the bottom level braced frame braces to a group. Click on two bottom level braces to select them.

30. Click the **Up One Gridline** button on the main toolbar twice to display the elevation at X=24.

31. Click on two bottom level braces to select them. There should now be four frame elements selected.

32. From the **Assign** menu choose **Group Name**…. This will display the Assign Group dialog box.

33. In this dialog box:

   • Type **BRACE1** in the edit box at the top of the Groups area.
   
   • Click the **Add New Group Name** button to define a group named BRACE1.
   
   • Click the **OK** button to assign the selected elements to the group named BRACE1.

34. Now we will assign the top level braced frame braces to a group. Click on two top level braces to select them.

35. Click the **Down One Gridline** button on the main toolbar twice to display the elevation at X=-24.

36. Click on two top level braces to select them. There should now be four frame elements selected.
37. From the **Assign** menu choose **Group Name**…. This will display the Assign Group dialog box.

38. In this dialog box:

   - Type **BRACE2** in the edit box at the top of the Groups area.
   - Click the **Add New Group Name** button to define a group named BRACE2.
   - Click the **OK** button to assign the selected elements to the group named BRACE2.

39. Now we will assign the moment frame girders to a group. Click on the **xz** button on the main toolbar to view an elevation in the X-Z plane. Note the title of the window is **X-Z Plane @ Y=24**.

40. Click on the roof level and second level beam on the **right** side of this elevation to select them.

41. Click the **Down One Gridline** button on the main toolbar twice to display the elevation at **Y=-24**.

42. Click on the roof level and second level beam on the **left** side of this elevation to select them. There should now be four frame elements selected.

43. From the **Assign** menu choose **Group Name**…. This will display the Assign Group dialog box.

44. In this dialog box:

   - Type **FRMGIRD** in the edit box at the top of the Groups area.
   - Click the **Add New Group Name** button to define a group named FRMGIRD.
   - Click the **OK** button to assign the selected elements to the group named FRMGIRD.

45. Finally we will assign the lower level columns, braces and the base joints to a group. This group can be used in the Group Joint Force Sum option (on the **Display** menu) to display the base shear. Click the **Perspective Toggle** button on the main toolbar. A perspective view of the X-Z elevation is displayed.

46. Click the **Set Intersecting Line Select Mode** button and select all of the bottom level columns. Note that in doing so you will also select the bottom level braces.

47. Click on the **xy** button on the main toolbar to view an elevation in the X-Y plane. Note the title of the window is **X-Y Plane @ Y=12**.
48. Click the **Down One Gridline** button on the main toolbar to display the plan at Z=0.

49. Select all of the joints at this level by “windowing”. There should now be 9 joints and 13 frame elements selected.

50. From the **Assign** menu choose **Group Name….** This will display the Assign Group dialog box.

51. In this dialog box:
   - Type **BASE** in the edit box at the top of the Groups area.
   - Click the **Add New Group Name** button to define a group named BASE.
   - Click the **OK** button to assign the selected elements to the group named BASE.

   *Note: The BASE group will be useful for determining base shears, overturning moments, total vertical loads.*

52. Click the **Save Model** button on the main toolbar, or select **Save** from the **File** menu to save the file.

This completes the assignment of groups.
**Step 7: Assigning Frame Sections**

Refer to Figure B-1 for the beam, column and brace element sections.

1. Click in the window labeled 3-D View to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. Click the **Set Elements** button on the main toolbar (or select **Set Elements…** from the **View** menu). This displays the Set Elements Dialog box.

3. In this dialog box:
   - In the Frames area check the Labels box.
   - In the Shells area check the Hide box.
   - Click the **OK** button.

4. Click in the window labeled X-Y Plane @ Z=0 to make sure it is active. Note when the window is active, its title bar will be highlighted.

5. Click the **Up One Gridline** button on the main toolbar twice to display the roof level plan at Z=24.

6. Click the **Set Elements** button on the main toolbar (or select **Set Elements…** from the **View** menu). This displays the Set Elements Dialog box.

7. In this dialog box:
   - In the Frames area check the Labels box.
   - In the Shells area check the Hide box.
   - Click the **OK** button.

8. In the window labeled X-Y Plane @ Z=24, click on frame elements 40, 45, 46 and 51 to select them.

   *Note: You can refer to Figures B-2 and B-3, as well as the screen, to identify the frame element numbers.*

9. From the **Assign** menu select **Frame** and then **Sections…** from the submenu. This will display the Define Frame Sections dialog box.
10. In the Frame Sections area click on the W16X26 name once to highlight it and then click the **OK** button. This assigns the W16X26 property to the selected frame elements. Note the other frame elements have the default FSEC1 assigned.

11. Click the **Show Undeformed Shape** button to clear the display of the assigned sections so that you can see the frame element labels again.

12. In the plan view, click on frame elements 41, 42, 44, 47, 49 and 50 to select them.

13. From the **Assign** menu select **Frame** and then **Sections...** from the submenu. This will display the Define Frame Sections dialog box.

14. In the Frame Sections area click on the W18X35 name once to highlight it and then click the **OK** button.

15. Click the **Show Undeformed Shape** button to clear the display of the assigned sections so that you can see the frame element labels again.

16. In the plan view, click on frame elements 43 and 48 to select them.

17. From the **Assign** menu select **Frame** and then **Sections...** from the submenu. This will display the Define Frame Sections dialog box.
18. In the Frame Sections area click on the W21X44 name once to highlight it and then click the **OK** button.

19. From the **Select** menu select **Select** and then **Groups...** from the submenu. This will display the Select Groups dialog box.

20. Click on the group name FRMGIRD once to highlight it and then click the **OK** button.

21. From the **Assign** menu select **Frame** and then **Sections...** from the submenu. This will display the Define Frame Sections dialog box.

22. In the Frame Sections area click on the W24X55 name once to highlight it and then click the **OK** button.

23. Click the **Show Undeformed Shape** button to clear the display of the assigned sections so that you can see the frame element labels again.

24. Click in the window labeled X-Y Plane @ Z=24 to make sure it is active.

25. Click the **Down One Gridline** button on the main toolbar to display the second floor plan at Z=12.

26. From the **Select** menu select **Select** and then **Labels** from the submenu. This will display the Select by Labels dialog box.

27. Click the Element Type drop-down box and select Frame.

   - Click the Element Type drop-down box and select Frame.

   - Type 15 in the Start Label edit box, 24 in the End Label edit box and 9 in the Increment edit box.

   - Click the **OK** button.

28. From the **Assign** menu select **Frame** and then **Sections...** from the submenu. This will display the Define Frame Sections dialog box.

29. In the Frame Sections area click on the W16X26 name once to highlight it and then click the **OK** button.

30. In the plan view, click on frame elements 16, 18, 19, 20, 21 and 23 to select them.

31. From the **Assign** menu select **Frame** and then **Sections...** from the submenu. This will display the Define Frame Sections dialog box.
32. In the Frame Sections area click on the W18X40 name once to highlight it and then click the OK button.

33. In the plan view, click on frame elements 17 and 22 to select them.

34. From the Assign menu select Frame and then Sections… from the submenu. This will display the Define Frame Sections dialog box.

35. In the Frame Sections area click on the W24X62 name once to highlight it and then click the OK button.

36. From the Assign menu select Clear Display of Assigns to clear the display of frame assigns from the plan view.

37. Click in the window labeled 3-D View to make sure it is active. Note when the window is active, its title bar will be highlighted.

38. Click the Set Elements button on the main toolbar (or select Set Elements… from the View menu). This displays the Set Elements Dialog box.

39. In this dialog box:
   - In the Frames area uncheck the Labels box.
   - Click the OK button.

40. From the Select menu select Select and then Groups… from the submenu. This will display the Select Groups dialog box.

41. Click on the group name BRACE1 once to highlight it and then click the OK button.

42. From the Assign menu select Frame and then Sections… from the submenu. This will display the Define Frame Sections dialog box.

43. In the Frame Sections area click on the TS5X5X1/4 name once to highlight it and then click the OK button.

44. From the Select menu select Select and then Groups… from the submenu. This will display the Select Groups dialog box.

45. Click on the group name BRACE2 once to highlight it and then click the OK button.

46. From the Assign menu select Frame and then Sections… from the submenu. This will display the Define Frame Sections dialog box.
47. In the Frame Sections area click on the TS4X4X1/4 name once to highlight it and then click the OK button.

48. From the Select menu select Select and then Groups… from the submenu. This will display the Select Groups dialog box.

49. Click on the group name FRCOLS once to highlight it and then click the OK button.

50. From the Assign menu select Frame and then Sections… from the submenu. This will display the Define Frame Sections dialog box.

51. In the Frame Sections area click on the W14X132 name once to highlight it and then click the OK button.

52. From the Select menu select Select and then Groups… from the submenu. This will display the Select Groups dialog box.

53. Click on the group name BRCOLS once to highlight it and then click the OK button.

54. From the Assign menu select Frame and then Sections… from the submenu. This will display the Define Frame Sections dialog box.

55. In the Frame Sections area click on the W8X58 name once to highlight it and then click the OK button.

56. From the Select menu select Select and then Groups… from the submenu. This will display the Select Groups dialog box.

57. Click on the group name COLS once to highlight it and then click the OK button.

58. From the Select menu select Deselect and then Groups… from the submenu. This will display the Select Groups dialog box.

59. In this dialog box:

   - Click on the group name FRCOLS once to select (highlight) it.

   - Hold down the Ctrl key on the keyboard and click on the BRCOLS group name once to highlight it and add it to the selection.

   - Click the OK button.

60. From the Assign menu select Frame and then Sections… from the submenu. This will display the Define Frame Sections dialog box.
61. In the Frame Sections area click on the W8X31 name once to highlight it and then click the **OK** button.

62. From the **Assign** menu select **Clear Display of Assigns** to clear the display of frame assigns from the 3-D view.

63. Click the **Save Model** button on the main toolbar, or select **Save** from the **File** menu to save the file.

This completes the assignment of frame section properties.
Step 8: Assigning Shell Sections

1. Click in the window labeled 3-D View to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. Click the Set Elements button on the main toolbar (or select Set Elements… from the View menu). This displays the Set Elements Dialog box.

3. In this dialog box:
   - In the Shells area uncheck the Hide box.
   - Click the OK button.

4. Click in the window labeled X-Y Plane @ Z=12 to make sure it is active. Note when the window is active, its title bar will be highlighted.

5. Click the Set Elements button on the main toolbar (or select Set Elements… from the View menu). This displays the Set Elements Dialog box.

6. In this dialog box:
   - In the Shells area uncheck the Hide box.
   - Click the OK button.

7. Click the Up One Gridline button on the main toolbar to display the roof level plan at Z=24.

8. From the Select menu select Select and then Groups… from the submenu. This will display the Select Groups dialog box.

9. Click on the group name ROOF once to highlight it and then click the OK button.

10. From the Assign menu select Shell and then Sections… from the submenu. This will display the Define Shell Sections dialog box.

11. In the Shell Sections area click on the ROOF name once to highlight it and then click the OK button.

12. From the Assign menu select Clear Display of Assigns to clear the display of shell assigns from the plan view.

13. Click the Save Model button on the main toolbar to save the file.

This completes the assignment of shell section properties.
**Step 9: Assigning Frame End Releases**

We will release the M3 and M2 moment at the ends of all non-moment frame girders, and release M3, M2 and torsional moment at the ends of all braces.

1. Click in the window labeled X-Y Plane @ Z=24 to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. From the Select menu select Select and then Groups… from the submenu. This will display the Select Groups dialog box.

3. Click on the group name ROOF once to highlight it, then, holding down the Ctrl key, click on the Group Named 2ND to add it to the selection. Click the OK button.

4. From the Select menu select Deselect and then Groups… from the submenu. This will display the Select Groups dialog box.

5. Click on the group name FRMGIRD once to highlight it and then click the OK button.

6. From the Assign menu select Frame and then Releases… from the submenu. This will display the Frame Releases dialog box.

   *Note: The end releases will be applied incorrectly to the roof beams at the braced frames as a result of this selection. We will fix that in items 8 through 18.*

7. In this dialog box:
   - Check the Start and End boxes for Moment M22 (Minor) and Moment M33 (Major).
   - Click the OK button to apply the releases.

8. Note that releases are applied at the center of the braced frame roof beams. This is not correct since the braced frame roof beams are continuous over the top of the chevron brace.

9. Click the Set Elements button on the main toolbar (or select Set Elements… from the View menu). This displays the Set Elements Dialog box.

10. In this dialog box check the Local Axes box and the Labels box in the Frames area and click the OK button. The local axes arrows appear as shown in Figure C-16.
Figure C-16: Frame Element Local Axes Arrows

Note: The local axes arrows are color-coded red, white and blue. The red arrow is always local axis 1, the white arrow is always local axis 2, and the blue arrow is always local axes 3. In the plan view, local axis 2 is pointing straight up and thus we can not see that arrow.

Note: For frame elements, local axis 1 always points along the longitudinal axis of the member from the start joint to the end joint. Thus we can use the local axes to tell which end is the start end for any frame element.

11. Click on frame elements 41 and 47 to select them. Note that for these elements, moments will be released at the start end only.

12. From the Assign menu select Frame and then Releases… from the submenu. This will display the Frame Releases dialog box.

13. In this dialog box:

- Check the Start box for Moment M22 (Minor) and Moment M33 (Major).
- Click the OK button to apply the releases.

14. Click on frame elements 44 and 50 to select them. Note that for these elements, moments will be released at the end joint only.
15. From the **Assign** menu select **Frame** and then **Releases...** from the submenu. This will display the Frame Releases dialog box.

16. In this dialog box:
   - Check the End box for Moment M22 (Minor) and Moment M33 (Major).
   - Click the **OK** button to apply the releases.

17. The member end releases have now been corrected. Click the **Set Elements** button on the main toolbar (or select **Set Elements...** from the **View** menu). This displays the Set Elements Dialog box.

18. In this dialog box uncheck the Local Axes box and the Labels box in the Frames area and click the **OK** button.

19. From the **Select** menu select **Select** and then **Groups...** from the submenu. This will display the Select Groups dialog box.

20. Click on the group name BRACE1 once to highlight it, then, holding down the Ctrl key, click on the Group Named BRACE2 to add it to the selection. Click the **OK** button.

21. From the **Assign** menu select **Frame** and then **Releases...** from the submenu. This will display the Frame Releases dialog box.

22. In this dialog box:
   - Check the Start and End boxes for Moment M22 (Minor), Moment M33 (Major) and the Start box for Torsion.

   *Note: You can apply a torsional release at one end of the frame element or the other, but not both simultaneously. If you applied a torsion release to both ends, the frame element would be free to spin about its longitudinal axis, and thus the structure would be unstable.*

   - Click the **OK** button to apply the releases.

23. From the **Assign** menu select **Clear Display of Assigns** to clear the display of frame releases from the plan view.

24. Click the **Save Model** button on the main toolbar, or select **Save** from the **File** menu to save the file.

This completes the assignment of frame element end releases.
Step 10: Defining Static Load Cases

We will define five static load cases. They are dead load, live load, earthquake in the X-direction, earthquake in the Y-direction and a load pattern to be used in the pushover analysis.

1. From the Define menu select Static Load Cases…. This will display the Define Static Load Case Names dialog box.

2. In this dialog box:
   - Type DL in the Load edit box.
   - Select Dead from the Type drop-down box.
   - Type 0 in the Self Weight Multiplier edit box.
   - Click the Change Load button.

   Note: In this example, if we had wanted the program to automatically include the self-weight of the structural members, we would have specified a non zero weight per unit volume in the Material data, and we would have put a self-weight multiplier of 1 on the DL load case only.

   - Type LL in the Load edit box.
   - Select Live from the Type drop-down box.
   - Type 0 in the Self Weight Multiplier edit box.
   - Click the Add New Load button.

   - Type EQX in the Load edit box.
   - Select Quake from the Type drop-down box.
   - Type 0 in the Self Weight Multiplier edit box.
   - Click the Add New Load button.

   - Type EQY in the Load edit box.
   - Select Quake from the Type drop-down box.
   - Type 0 in the Self Weight Multiplier edit box.
   - Click the Add New Load button.
• Type **PUSHPAT** in the Load edit box.

• Select OTHER from the Type drop-down box.

• Type **0** in the Self Weight Multiplier edit box.

• Click the **Add New Load** button.

3. Click the **OK** button.

4. Click the **Save Model** button on the main toolbar, or select **Save** from the **File** menu to save the file.

This completes the definition of static load cases.
Step 11: Assigning Frame Static Loads

Note that the beam span loading is indicated in Figure B-4.

1. Click in the window labeled X-Y Plane @ Z=24 to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. Click the Set Elements button on the main toolbar (or select Set Elements… from the View menu). This displays the Set Elements Dialog box.

3. In this dialog box check the Labels box in the Frames area, check the Hide box in the Shells area and click the OK button.

4. Click the Perspective Toggle button on the main toolbar. A perspective view of the X-Y plan is displayed.

5. From the View menu select Set Limits…. This displays the Set limits dialog box.

6. In this dialog box type 23 in the Min edit box in the Set Z-Axis Limits area and click the OK button to change the limits such that only the roof beam elements show.

7. Select roof beams 39, 40, 51 and 52 by clicking on them.

8. From the Assign menu select Frame Static Loads… and then Point and Uniform… from the submenu. This will display the Point and Uniform Span Loads dialog box.

9. In this dialog box:

   - Select DL from the Load Case Name drop-down box.

   - In the Load Type and Direction area, select the Forces option, and select Global Z from the drop-down Direction box.

   - In the Options area, select the Add to Existing Loads option.

   - In the Uniform Load area, type -0.40, or just type -.4.

   Note: Take care to make sure you enter the minus sign with the load. The load is input in the global Z direction, thus the minus sign indicates a downward load.

   - Click the OK button to apply the load.

10. Click the Restore Previous Selection button on the side toolbar (or select Get Previous Selection from the Select menu).
11. From the **Assign** menu select **Frame Static Loads**... and then **Point and Uniform**... from the submenu. This will display the Point and Uniform Span Loads dialog box.

12. In this dialog box:

- Select LL from the Load Case Name drop-down box.
- In the Uniform Load area, type -.12. Don’t forget the minus sign.
- Click the **OK** button to apply the load.

13. Select roof beams 41, 42, 44, 47, 49 and 50 by clicking on them.

14. From the **Assign** menu select **Frame Static Loads**... and then **Point and Uniform**... from the submenu. This will display the Point and Uniform Span Loads dialog box.

15. In this dialog box:

- Select DL from the Load Case Name drop-down box.
- In the Uniform Load area, type -.16.
- Click the **OK** button to apply the load.

*Note: The point load for beams 41/44 and 47/50 can either be input as a joint load, or as a beam span load at the end of a beam. We will input it as a beam span load.*

16. Select roof beams 41 and 47 by clicking on them.

17. From the **Assign** menu select **Frame Static Loads**... and then **Point and Uniform**... from the submenu. This will display the Point and Uniform Span Loads dialog box.

18. In this dialog box:

- Select DL from the Load Case Name drop-down box.
- In the Options area, select the Add to Existing Loads option.
- In the Point Loads area there are four sets of Distance and Load boxes labeled 1 through 4. In the first set of boxes input 1 in the Distance box and -5.76 in the Load box. Make sure the Relative Distance From End I option is selected.
- In the Uniform Load area, type 0.
- Click the OK button to apply the load.

19. Click the Restore Previous Selection button on the side toolbar (or select Get Previous Selection from the Select menu).

20. From the Assign menu select Frame Static Loads… and then Point and Uniform… from the submenu. This will display the Point and Uniform Span Loads dialog box.

21. In this dialog box:
   - Select LL from the Load Case Name drop-down box.
   - In the Point Loads area type 1 in the first Distance box and -2.88 in the first Load box.
   - Click the OK button to apply the load.

22. Select roof beams 42 and 49 by clicking on them.

23. From the Assign menu select Frame Static Loads… and then Point and Uniform… from the submenu. This will display the Point and Uniform Span Loads dialog box.

24. In this dialog box:
   - Select DL from the Load Case Name drop-down box.
   - In the Point Loads area type .5 in the first Distance box and -5.76 in the first Load box.
   - Click the OK button to apply the load.

25. Click the Restore Previous Selection button on the side toolbar (or select Get Previous Selection from the Select menu).

26. From the Assign menu select Frame Static Loads… and then Point and Uniform… from the submenu. This will display the Point and Uniform Span Loads dialog box.

27. In this dialog box:
   - Select LL from the Load Case Name drop-down box.
   - In the Point Loads area type -2.88 in the first Load box.
   - Click the OK button to apply the load.
28. Select roof beams 45 and 46 by clicking on them.

29. From the Assign menu select Frame Static Loads... and then Point and Uniform... from the submenu. This will display the Point and Uniform Span Loads dialog box.

30. In this dialog box:
   - Select DL from the Load Case Name drop-down box.
   - In the Point Loads area type 0 in the first Distance box and 0 in the first Load box.
   - In the Uniform Load area, type .48.
   - Click the OK button to apply the load.

   Note: Because of the perspective view, you will not see this load after it is applied. To see it, click the 3-D View button. To return to the perspective view, click the xy 2-D View button and then click the Perspective Toggle button.

31. Click the Restore Previous Selection button on the side toolbar (or select Get Previous Selection from the Select menu).

32. From the Assign menu select Frame Static Loads... and then Point and Uniform... from the submenu. This will display the Point and Uniform Span Loads dialog box.

33. In this dialog box:
   - Select LL from the Load Case Name drop-down box.
   - In the Uniform Load area, type -.24.
   - Click the OK button to apply the load.

34. Select roof beams 43 and 48 by clicking on them.

35. From the Assign menu select Frame Static Loads... and then Point and Uniform... from the submenu. This will display the Point and Uniform Span Loads dialog box.

36. In this dialog box:
   - Select DL from the Load Case Name drop-down box.
   - In the Point Loads area type .5 in the first Distance box and -11.52 in the first Load box.
   - In the Uniform Load area, type 0.
Click the OK button to apply the load.

37. Click the Restore Previous Selection button on the side toolbar (or select Get Previous Selection from the Select menu).

38. From the Assign menu select Frame Static Loads… and then Point and Uniform… from the submenu. This will display the Point and Uniform Span Loads dialog box.

39. In this dialog box:
   - Select LL from the Load Case Name drop-down box.
   - In the Point Loads area type -5.76 in the first Load box.
   - Click the OK button to apply the load.

40. From the View menu select Set Limits…. This displays the Set limits dialog box.

41. In this dialog box type 11 in the Min edit box and 13 in the Max edit box in the Set Z-Axis Limits area and click the OK button to change the limits such that only the second floor beam elements show.

Figure C-17: 3-D View With Limits Set To Show Second Level
42. Click on the 3-D View button to change the view to a three dimensional view. See Figure C-17.

43. Select second level beams 14, 15, 24 and 25 by clicking on them.

44. From the Assign menu select Frame Static Loads... and then Point and Uniform... from the submenu. This will display the Point and Uniform Span Loads dialog box.

45. In this dialog box:
   - Select DL from the Load Case Name drop-down box.
   - In the Point Loads area type 0 in the first Distance box and 0 in the first Load box.
   - In the Uniform Load area, type -0.72.
   - Click the OK button to apply the load.

46. Click the Restore Previous Selection button on the side toolbar (or select Get Previous Selection from the Select menu).

47. From the Assign menu select Frame Static Loads... and then Point and Uniform... from the submenu. This will display the Point and Uniform Span Loads dialog box.

48. In this dialog box:
   - Select LL from the Load Case Name drop-down box.
   - In the Uniform Load area, type -.3.
   - Click the OK button to apply the load.

49. Select second level beams 16, 18, 21 and 23 by clicking on them.

50. From the Assign menu select Frame Static Loads... and then Point and Uniform... from the submenu. This will display the Point and Uniform Span Loads dialog box.

51. In this dialog box:
   - Select DL from the Load Case Name drop-down box.
   - In the Point Loads area type .5 in the first Distance box and -11.52 in the first Load box.
   - In the Uniform Load area, type -.24.
   - Click the OK button to apply the load.
52. Click the **Restore Previous Selection** button on the side toolbar (or select **Get Previous Selection** from the **Select** menu).

53. From the **Assign** menu select **Frame Static Loads…** and then **Point and Uniform…** from the submenu. This will display the Point and Uniform Span Loads dialog box.

54. In this dialog box:
   - Select LL from the Load Case Name drop-down box.
   - In the Point Loads area type **-7.2** in the first Load box.
   - In the Uniform Load area, type **0**.
   - Click the **OK** button to apply the load.

55. Select second level beams 19 and 20 by clicking on them.

56. From the **Assign** menu select **Frame Static Loads…** and then **Point and Uniform…** from the submenu. This will display the Point and Uniform Span Loads dialog box.

57. In this dialog box:
   - Select DL from the Load Case Name drop-down box.
   - In the Point Loads area type **0** in the first Distance box and **0** in the first Load box.
   - In the Uniform Load area, type **-0.96**.
   - Click the **OK** button to apply the load.

58. Click the **Restore Previous Selection** button on the side toolbar (or select **Get Previous Selection** from the **Select** menu).

59. From the **Assign** menu select **Frame Static Loads…** and then **Point and Uniform…** from the submenu. This will display the Point and Uniform Span Loads dialog box.

60. In this dialog box:
   - Select LL from the Load Case Name drop-down box.
   - In the Uniform Load area, type **-0.6**.
   - Click the **OK** button to apply the load.
61. Select second level beams 17 and 22 by clicking on them.

62. From the Assign menu select Frame Static Loads… and then Point and Uniform… from the submenu. This will display the Point and Uniform Span Loads dialog box.

63. In this dialog box:
   - Select DL from the Load Case Name drop-down box.
   - In the Point Loads area type 0.5 in the first Distance box and -23.04 in the first Load box.
   - In the Uniform Load area, type 0.
   - Click the OK button to apply the load.

64. Click the Restore Previous Selection button on the side toolbar (or select Get Previous Selection from the Select menu).

65. From the Assign menu select Frame Static Loads… and then Point and Uniform… from the submenu. This will display the Point and Uniform Span Loads dialog box.

66. In this dialog box:
   - Select LL from the Load Case Name drop-down box.
   - In the Point Loads area type -14.4 in the first Load box.
   - Click the OK button to apply the load.

67. From the View menu select Set Limits…. This displays the Set limits dialog box.

68. In this dialog box click the Show All button in the Set Z-Axis Limits area and click the OK button to change the limits such that the entire model is displayed.

69. From the Assign menu select Clear Display of Assigns to clear the display of beam span loading. Note that the frame element labels remain because they were turned on using the Set Elements command.

70. Click the xy 2-D View button on the main toolbar to return to a plan view. Note the the window title is X-Y Plane @ Z=24.

71. Click the Save Model button on the main toolbar, or select Save from the File menu to save the file.

This completes the assignment of frame static loads.
**Step 12: Assigning Shell Static Loads**

The roof level lateral earthquake loads are assigned as shell static loads.

1. Click in the window labeled X-Y Plane @ Z=24 to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. Click the **Set Elements** button on the main toolbar (or select **Set Elements** from the **View** menu). This displays the Set Elements Dialog box.

3. In this dialog box uncheck the Hide box in the Shells area and click the **OK** button.

4. From the **Select** menu select **Select** and then **Groups** from the submenu. This will display the Select Groups dialog box.

5. Click on the group name ROOF once to highlight it then click the **OK** button.

6. From the **Assign** menu select **Shell Static Loads** and then **Uniform** from the submenu. This will display the Shell Uniform Loads dialog box.

7. In this dialog box:
   - Select EQX from the Load Case Name drop-down box.
   - In the Uniform Load area type .0074 in the Load box and select Global X from the dropdown Dir box.
   - Select Add To Existing Loads in the Options area.
   - Click the **OK** button to apply the load.

8. Click the **Restore Previous Selection** button on the side toolbar (or select **Get Previous Selection** from the **Select** menu).

9. From the **Assign** menu select **Shell Static Loads** and then **Uniform** from the submenu. This will display the Shell Uniform Loads dialog box.

10. In this dialog box:
    - Select EQY from the Load Case Name drop-down box.
    - In the Uniform Load area type .0113 in the Load box and select Global Y from the dropdown Dir box.
    - Click the **OK** button to apply the load.
11. Click the drop down box in the status bar to change the units to lb-ft. Observe that the shell load shown on the screen is now 11.30 instead of 0.01. Sometimes it is convenient to change units when viewing input loads and output results.

12. Click the drop down box in the status bar to change the units back to kip-ft.

13. From the Assign menu select Clear Display of Assigns to clear the display of shell loading.

14. Click the Save Model button on the main toolbar to save the file.

This completes the assignment of shell static loads.
Step 13: Assigning Joint Static Loads

The second level lateral earthquake loads (load cases EQX and EQY) are assigned as joint static loads. Also the static load pattern to be used in the pushover analysis, PUSHPAT is assigned as joint static loads.

Note the static load pattern for the pushover analysis could be any combination of joint, frame and shell loading.

1. Click in the window labeled X-Y Plane @ Z=24 to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. Click the Down One Gridline button on the main toolbar to display the second floor plan at Z=12.

3. Click the Set Elements button on the main toolbar (or select Set Elements… from the View menu). This displays the Set Elements Dialog box.

4. In this dialog box uncheck the Labels box in the Frames area, check the Labels box in the Joints area and click the OK button. Note we are leaving the Restraints box in the Joints area checked.

5. Click joint 14 to select it.

6. From the Assign menu select Joint Static Loads… and then Forces… from the submenu. This will display the Joint Forces dialog box.

7. In this dialog box:
   - Select EQX from the Load Case Name drop-down box.
   - In the Options area, select the Add to Existing Loads option.
   - In the Loads area type 2.67 in the Force Global X edit box.
   - Click the OK button to apply the load.

8. Click the Restore Previous Selection button on the side toolbar (or select Get Previous Selection from the Select menu).

9. From the Assign menu select Joint Static Loads… and then Forces… from the submenu. This will display the Joint Forces dialog box.

10. In this dialog box:
    - Select EQY from the Load Case Name drop-down box.
- In the Loads area type 0 in the Force Global X edit box.
- In the Loads area type 3.83 in the Force Global Y edit box.
- Click the OK button to apply the load.

11. Click on joints 11, 13, 15 and 17 to select them.

12. From the Assign menu select Joint Static Loads… and then Forces… from the submenu. This will display the Joint Forces dialog box.

13. In this dialog box:
   - Select EQX from the Load Case Name drop-down box.
   - In the Options area, select the Add to Existing Loads option.
   - In the Loads area type 2 in the Force Global X edit box.
   - In the Loads area type 0 in the Force Global Y edit box.
   - Click the OK button to apply the load.

14. Click the Restore Previous Selection button on the side toolbar (or select Get Previous Selection from the Select menu).

15. From the Assign menu select Joint Static Loads… and then Forces… from the submenu. This will display the Joint Forces dialog box.

16. In this dialog box:
   - Select EQY from the Load Case Name drop-down box.
   - In the Loads area type 0 in the Force Global X edit box.
   - In the Loads area type 2.88 in the Force Global Y edit box.
   - Click the OK button to apply the load.

17. Click on joints 10, 12, 16 and 18 to select them.

18. From the Assign menu select Joint Static Loads… and then Forces… from the submenu. This will display the Joint Forces dialog box.

19. In this dialog box:
- Select EQX from the Load Case Name drop-down box.
- In the Options area, select the Add to Existing Loads option.
- In the Loads area type 1.33 in the Force Global X edit box.
- In the Loads area type 0 in the Force Global Y edit box.
- Click the OK button to apply the load.

20. Click the Restore Previous Selection button on the side toolbar (or select Get Previous Selection from the Select menu).

21. From the Assign menu select Joint Static Loads… and then Forces… from the submenu. This will display the Joint Forces dialog box.

22. In this dialog box:
   - Select EQY from the Load Case Name drop-down box.
   - In the Loads area type 0 in the Force Global X edit box.
   - In the Loads area type 1.92 in the Force Global Y edit box.
   - Click the OK button to apply the load.

23. We will now define the PUSHPAT load pattern that will be used in the pushover analysis. It will be a triangular distribution of load over the height of the building. From the Select menu select Select and then Groups… from the submenu. This will display the Select Groups dialog box.

   Note: Our purpose here is to input an inverted triangular loading pattern over the height of the building. Thus we will put 1 kip loads at 9 second level joints (9 kips total) and 2 kip loads at 9 roof level joints (18 kips total). We could assign the 9 kips at the second level and 18 kips at the roof level to the joints on a tributary area basis, or some other basis, but we will not consider any such refinement in this example.

24. Click on the group name 2ND and then click the OK button.

25. From the Assign menu select Joint Static Loads… and then Forces… from the submenu. This will display the Joint Forces dialog box.

26. In this dialog box:
   - Select PUSHPAT from the Load Case Name drop-down box.
- In the Loads area type 1 in the Force Global X edit box.
- In the Loads area type 0 in the Force Global Y edit box.
- Click the OK button to apply the load.

27. Click the Up One Gridline button on the main toolbar to display the roof level plan at Z=24.

28. From the Select menu select Select and then Groups… from the submenu. This will display the Select Groups dialog box.

29. Click on the group name ROOF and then click the OK button.

30. Click on joints 22 and 26 to deselect them.

31. From the Assign menu select Joint Static Loads… and then Forces… from the submenu. This will display the Joint Forces dialog box.

32. In this dialog box:
   - Select PUSHPAT from the Load Case Name drop-down box.
   - In the Loads area type 2 in the Force Global X edit box.
   - Click the OK button to apply the load.

33. From the Assign menu select Clear Display of Assigns to clear the display of joint loads. Note that the joint element labels remain because they were turned on using the Set Elements command.

34. Click the Save Model button on the main toolbar, or select Save from the File menu to save the file.

This completes the assignment of joint static loads.
Step 14: Assigning Joint Masses

We will add joint masses consistent with those shown in Table B-1.

1. Click in the window labeled X-Y Plane @ Z=24 to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. Click joint 24 to select it.

3. From the Assign menu select Joint and then Masses… from the submenu. This will display the Joint Masses dialog box.

4. In this dialog box:
   - Type .72 in the Direction 1 edit box in the Masses in Local Directions area.
   - Type .72 in the Direction 2 edit box in the Masses in Local Directions area.
   - In the Options area, select the Add to Existing Masses option.
   - Click the OK button to apply the mass.

   Note: If we wanted to obtain vertical direction mode shapes we should include a Direction 3 mass as well.

5. Click joints 20, 23, 25 and 28 to select them.

6. From the Assign menu select Joint and then Masses… from the submenu. This will display the Joint Masses dialog box.

7. In this dialog box:
   - Type .48 in both the Direction 1 edit box and the Direction 2 edit box in the Masses in Local Directions area.
   - Click the OK button to apply the mass.

8. Click joints 19, 21, 27 and 29 to select them.

9. From the Assign menu select Joint and then Masses… from the submenu. This will display the Joint Masses dialog box.

10. In this dialog box:
    - Type .3 in both the Direction 1 edit box and the Direction 2 edit box in the Masses in Local Directions area.
- Click the **OK** button to apply the mass.

11. Click the **Down One Gridline** button on the main toolbar to display the second floor plan at Z=12.

12. Click joint 14 to select it.

13. From the **Assign** menu select **Joint** and then **Masses...** from the submenu. This will display the Joint Masses dialog box.

14. In this dialog box:
   - Type **1.45** in both the Direction 1 edit box and the Direction 2 edit box in the Masses in Local Directions area.
   - Click the **OK** button to apply the mass.

15. Click joints 11, 13, 15 and 17 to select them.

16. From the **Assign** menu select **Joint** and then **Masses...** from the submenu. This will display the Joint Masses dialog box.

17. In this dialog box:
   - Type **.9** in both the Direction 1 edit box and the Direction 2 edit box in the Masses in Local Directions area.
   - Click the **OK** button to apply the mass.

18. Click joints 10, 12, 16 and 18 to select them.

19. From the **Assign** menu select **Joint** and then **Masses...** from the submenu. This will display the Joint Masses dialog box.

20. In this dialog box:
   - Type **.55** in both the Direction 1 edit box and the Direction 2 edit box in the Masses in Local Directions area.
   - Click the **OK** button to apply the mass.

21. From the **Assign** menu select **Clear Display of Assigns** to clear the display of joint masses. Note that the joint element labels remain because they were turned on using the Set Elements command.
22. Click the **Set Elements** button on the main toolbar (or select **Set Elements…** from the **View** menu). This displays the Set Elements Dialog box.

23. In this dialog box uncheck the Labels box in the Joints area and click the OK button. This will turn off the display of joint labels.

24. Click the **Save Model** button on the main toolbar, or select **Save** from the **File** menu to save the file.

This completes the assignment of joint masses.
Step 15: Assigning Diaphragm Constraints

We will assign a diaphragm constraint at the second level to simulate a rigid diaphragm.

1. Click in the window labeled X-Y Plane @ Z=12 to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. Select all elements at the second level by “windowing”.

3. From the Assign menu choose Joint, and then Constraints… from the submenu. This will display the Constraints dialog box.

4. In this dialog box:
   - In the Click To area, click the drop-down box and select Add Diaphragm. This will display the Diaphragm Constraint dialog box.
   - In this dialog box:
     ✓ Type 2NDDIA in the Constraint Name edit box.
     ✓ Select the Z Axis option in the Constraint Axis area.
     ✓ Click the OK button.
   - Click the OK button to exit the Constraints dialog box and assign the second floor level diaphragm constraint.

   Note: The joints change colors indicating the constraint has been assigned.

5. From the Assign menu select Clear Display of Assigns to clear the display of joint constraints.

6. Click the Save Model button on the main toolbar, or select Save from the File menu to save the file.

This completes the assigning of diaphragm constraints.
Step 16: Static and Dynamic Analysis (Not Pushover)

In this step we will set the analysis options for the static and dynamic analysis (not pushover) and run the analysis.

1. From the Analyze menu select Set Options…. This will display the Analysis Options dialog box.

2. In this dialog box:
   - Check the Dynamic Analysis check box.
   - Click on the Set Dynamic Parameters button. This will display the Dynamic Analysis Parameters dialog box.
   - In this dialog box:
     - Type 6 in the Number Of Modes edit box
     - In the Type of Analysis area select the Eigenvectors option.
     - Accept the other default values in the dialog box.
     - Click the OK button.
   - Check the Generate Output check box.

     Note: The Generate Output option creates output that will be stored in the *.out file where * represents your SAP2000 filename.

   - Click on the Set Output Options button. This will display the Select Output Results dialog box.
   - In this dialog box:
     - Check the Displacements check box
     - Click on the Select/Show Loads button adjacent to the Displacements check box. This displays the Select Output dialog box.
     - Click on the EQX load case to highlight it. Hold down the control key and click on the EQY load case to add it to the selection.
     - Click the OK button to close the Select Output dialog box.
     - Click the OK button to close the Select Output Results dialog box.
   - Click the OK button again to exit the Analysis Options dialog box:
Note: It is important to note that when displacements or force are specified to be printed in the *.out files using the Generate Output option, data for each and every joint or element is printed. You have no control over this. For larger problems this can lead to very large and unwieldy output files. See the notes at the ends of steps 18 and 19 for information on other printing options.

Note: If you are running a large model, you may want/need to increase the memory allocated to SAP2000 above the default 2000 Kb. You can do this in the Analysis options dialog box.

3. Click the Run Analysis button on the main toolbar.

Note: You can also click the Analyze menu and select Run or select Run Minimized to run the analysis. Run minimized will perform the execution in the background, i.e., it will allow you to minimize SAP2000 while the analysis is being carried out. It also provides a Cancel button that allows you to stop a run that is in progress.

4. A window is opened in which various phases of analysis are progressively reported. When the analysis is complete the screen will display as shown in Figure C-18.

![Figure C-18: Screen Message When Analysis Is Complete](image-url)
5. Use the scroll bar to review the analysis messages and check for any error or warning messages (there should be none).

*Note:* The information in the scrolling analysis window can also be found in the *.log file, where the * represents your filename.

6. Click the **OK** button in the Analysis window to close it. Note that the 3-D window now shows the first mode shape.

This completes the static and dynamic analysis.
**Step 17: Reviewing Mode Shapes**

In this step we will review the mode shapes.

1. Note that the first mode shape is currently displayed in the 3-D View window. Click on this window to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. Click the **Display Mode Shape** button on the main toolbar, (or select **Show Mode Shape**… from the **Display** menu). The Mode Shape dialog box appears.

3. In this dialog box:
   - Set the mode number to 1 in the Mode Number area.
   - Set the scale factor to 1 in the Scale Factor area.
   - Select (i.e., check) the Wire Shadow and Cubic Curve options in the Options area.
   - Click the **OK** button to redisplay the first mode.

4. Click the **Start Animation** button, located in the status bar at the bottom of the SAP2000 window, to animate the mode shape.

5. Click the **Right Arrow** button, located in the status bar at the bottom of the screen, to view the next mode shape.

   *Note: When viewing mode shapes, the right and left arrow buttons, located in the status bar at the bottom of the screen, provide an easy way to view the next (right arrow), or previous (left arrow) mode shape.*

6. Using the Right Arrow button, review modes 2 through 6. Note that mode 1 is predominantly in the X-direction; we will use this information when creating pushover load cases.

   *Note: Additional information on mode shapes including modal periods and frequencies, modal participation factors and modal participating mass ratios can be found in the *.OUT file.*

7. After viewing mode 6, click the **Stop Animation** button, located in the status bar at the bottom of the SAP2000 window, to stop the mode shape animation.

8. Click the **Show Undeformed Shape** button to clear the display of mode shapes.

This completes the review of displaying mode shapes.
Step 18: Reviewing Deformed Shapes

In this step we will demonstrate methods for reviewing the deformed shapes and displacements.

1. Click in the window labeled 3-D View to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. Click the Display Static Deformed Shape button, (or select Show Deformed Shape… from the Display menu). The Deformed Shape dialog box appears.

3. In this dialog box:
   - Select the EQX Load Case from the Load drop-down box.
   - Select the Auto scaling option in the Scaling area.
   - Check both the Wire Shadow and the Cubic curve boxes in the Options area.
   - Click the OK button to display the deformed shape.

4. Click the Start Animation button, located in the status bar at the bottom of the SAP2000 window, to animate the deformed shape.

5. Click the Stop Animation button, located in the status bar at the bottom of the SAP2000 window, to stop the deformed shape animation.

6. Click the Right Arrow button, located in the status bar at the bottom of the screen, to view the next deformed shape, based on the EQY static load.

   Note: When viewing deformed shapes, the right and left arrow buttons, located in the status bar at the bottom of the screen, provide an easy way to view the next (right arrow), or previous (left arrow) deformed shape. You can easily cycle through all of the load cases in this manner.

7. Right click on any joint in the 3-D view to bring up a dialog box with displacements for all six degrees of freedom (UX, UY, UZ, RX, RY, RZ) for that joint. When done viewing these displacements, right click another joint, or left click anywhere to close the dialog box.

8. From the Display menu select Set Output Table Mode… to display the Select Output dialog box.

9. All of the load cases in the Select Output dialog box should be selected (highlighted). If they are not, click on each one while holding down the Ctrl key to select them. Click the OK button to accept this selection.

   Note: If we wanted to, we could select only one, or a few load cases, instead of all of them.
10. Right click any joint to get a table of displacements for the joint. Note you can print this table by selecting **Print** from its associated **File** menu. When done viewing this table click the “X” in the upper right-hand corner to close it.

**Note:** You can also right click a frame element or a shell element to get a table of forces for that element.

**Note:** You can also print joint displacements from the graphic interface without having to first view them in a table. With this method you can control the elements for which the output is provided (printed). After the analysis has been run, select all of the joints for which you want displacement output. (Note that if you don’t select any elements, then this feature will give you output for all elements.) Then select **Print Output Tables...** from the **File** menu. Fill in the resulting Print Output Tables dialog box, remembering to select the load cases for which you want output, and click the **OK** button. Note that with the Print Output Tables feature you have the option of printing to the printer or to a file. If you print to a file, an ASCII file is created which you can review in a text editor or word processor.

11. Click the **Show Undeformed Shape** button ![Show Undeformed Shape](image) to clear the display of deformed shapes.

This completes the review of deformed shapes and displacements.
**Step 19: Reviewing Forces and Stresses**

In this step we will demonstrate methods for reviewing the forces and stresses in frame and shell elements.

1. Click in the window labeled 3-D View to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. Click the **Member Force Diagram for Frames** button, (or select **Show Element Forces/Stresses** from the **Display** menu and then select **Frames...** from the submenu). The Member Force Diagram for Frames dialog box appears.

3. In this dialog box:
   - Select the EQX Load Case from the Load drop-down box.
   - Select the Moment 3-3 option in the Component area.
   - Select the Auto scaling option in the Scaling area.
   - Check the Fill Diagram box.
   - Click the **OK** button to display the moment diagrams as filled shapes.

4. Right click on any element to display a dialog box that allows you to see the moment at any point along the element. When done viewing, right click on another element or left click anywhere to close the dialog box.

5. Click the **Member Force Diagram for Frames** button, again (or select **Show Element Forces/Stresses** from the **Display** menu and then select **Frames...** from the submenu). The Member Force Diagram for Frames dialog box appears.

6. In this dialog box:
   - Uncheck the Fill Diagram box.
   - Check the Show Values on Diagram box.
   - Click the **OK** button to display the moment diagrams with critical values shown.

7. Right click on any element to display a dialog box that allows you to see the moment at any point along the element. When done viewing, right click on another element or left click anywhere to close the dialog box.
8. Click the **Element Force/Stress Contours for Shells** button, (or select **Show Element Forces/Stresses** from the **Display** menu and then select **Shells...** from the submenu). The Element Force Stress/Contours for Shells dialog box appears.

9. In this dialog box:
   - Select the EQX Load Case from the Load drop-down box.
   - Select the Forces option button.
   - Select the F12 component by checking its box.
   - Accept the rest of the default values.
   - Click the **OK** button to display the shell element forces.

10. Suppose we now want to see the Y-direction force transferred from the roof diaphragm to joints 19, 23, 26 and 27 in static load case EQY. To do this we will use the Group Joint Force Sum feature. Click in the window labeled X-Y Plane @ Z=12 to make sure it is active. Note when the window is active, its title bar will be highlighted.

11. Click the **Up One Gridline** button on the main toolbar to display the roof level plan at Z=24.

12. Click the **Set Elements** button on the main toolbar (or select **Set Elements...** from the **View** menu). This displays the Set Elements Dialog box.

13. In this dialog box check the Labels box in the Joints area, uncheck the Hide box in the Shells area if it is checked, check the Labels box in the Shells area and click the **OK** button. This will turn on the display of joint labels and shell labels.

14. Click on joints 19, 23, 26 and 27 and on shells 2, 4 and 6.

15. From the **Assign** menu choose **Group Name...**. This will display the Assign Group dialog box.

16. In this dialog box:
   - Type **ROOFSHR** in the edit box at the top of the Groups area.
   - Click the **Add New Group Name** button to define a group named ROOFSHR.
   - Click the **OK** button to assign the selected elements to the group named ROOFSHR.

17. From the **Display** menu select **Set Output Table Mode...** to display the Select Output dialog box.
18. All of the load cases in the Select Output dialog box should be selected (highlighted). If they are not, then click on each one while holding down the Ctrl key to select them. Click the OK button to accept this selection.

*Note: If we wanted to, we could select only one, or a few load cases, instead of all of them.*

19. From the Display menu select Show Group Joint Force Sums… to display the Select Groups dialog box.

20. In that dialog box click on the ROOFSHR group to highlight it and click the OK button.

*Note: We could select more than one group at this time if we wanted to.*

21. The group joint force sum for the ROOFSHR group is displayed for each load case. The Y-direction force transferred from the roof diaphragm to joints 19, 23, 26 and 27 in static load case EQY is the FY force for load EQY.

*Note: We can use groups to define section cuts through shell elements (and frame elements) at any location and then use the Group Joint Force Sum feature to see the forces acting at that section cut. To do this, imagine a section cut through the structure. The section cut may be through the entire structure or through a portion of the structure. Select all of the elements that the section cut passes through, and select all of the joints connected to those elements on one side of the section cut. Note you must select both the shell and/or frame elements and the joints. Define a group that includes all of the selected items. Use the Show Group Joint Force Sum option on the Display menu to show the forces at the section cut.*

22. We can display the base shear using the BASE group we previously defined. From the Display menu select Show Group Joint Force Sums… to display the Select Groups dialog box. In that dialog box click on the BASE group to highlight it and click the OK button.

23. Click the Set Elements button on the main toolbar (or select Set Elements… from the View menu). This displays the Set Elements Dialog box.

24. In this dialog box uncheck the Labels box in the Joints area, uncheck the Labels box in the Shells area and click the OK button. This will turn off the display of joint labels and shell labels.

25. We can display output tables of element forces on the screen.

26. From the Display menu select Set Output Table Mode… to display the Select Output dialog box.
27. In the Select Output dialog box click on the EQX Load Case to highlight it and then hold down Ctrl key and click on the EQY Load Case to highlight it. Click the OK button to accept this selection.

28. Right click any frame or shell element to get a table of forces for that element.

*Note: You can also right click a joint to get a table of joint displacements.*

*Note: You can also print frame and shell element forces from the graphic interface without having to first view them in a table. With this method you can control the elements for which the output is provided (printed). After the analysis has been run, select all of the frame and/or shell elements for which you want force output. (Note that if you don’t select any elements, then this feature will give you output for all elements.) Then select **Print Output Tables…** from the **File** menu. Fill in the resulting Print Output Tables dialog box, remembering to select the load cases for which you want output, and click the **OK** button. Note that with the Print Output Tables feature you have the option of printing to the printer or to a file. If you print to a file, an ASCII file is created which you can review in a text editor or word processor.

This completes the review of forces and stresses.
Step 20: Performing a Steel Design Stress Check

Now we will perform a steel design stress check.

1. From the Options menu, click Preferences… to display the Preferences dialog box.

2. In this dialog box:
   - Select the Steel tab.
   - Click the Steel Design Code drop-down box to review the available options. Select the AISC-ASD89 option.
   - Click the OK button to close the Preferences dialog box.

3. Click on the Design menu. Note that the Steel Design option on the menu is checked indicating a steel design will be done.

   Note: Either the Steel Design or Concrete Design option can be checked on the Design menu, but not both at the same time.


   Note: SAP2000 automatically creates appropriate load combinations for the selected design code. For this model, using AISC-ASD89, these ten default load combinations will include DL, DL + LL, DL + LL + EQX, DL + LL - EQX, DL + LL + EQY, DL + LL – EQY, DL +EQX, DL – EQX, DL + EQY and DL – EQY.

5. In this dialog box:
   - Click on the DSTL1 combination in the Design Combos box to highlight it.
   - Click the Show button to review the combination.

   Note: Clicking the Remove button when a Design Combo is highlighted will remove that combination from the Design Combo box and put it in the List of Combos box. Only the design combinations in the Design Combo box are in the design stress check.

   Note: You can also add your own combinations to the design combinations. To define a new load combination, click Load Combinations… on the Define menu. To add the new load combination to the design list, highlight the new load combination name, that will be in the List of Combos box in the Design Load Combinations Selection dialog box, and click the Add button.

   - Review the other combinations in a similar manner.
- Press the **OK** button twice to close all dialog boxes.

6. Click in the window labeled 3-D View to make sure it is active.

7. Click the **Set Elements** button on the main toolbar (or select **Set Elements...** from the **View** menu). This displays the Set Elements Dialog box.

8. In this dialog box check the Hide box in the Shells area and click the OK button. This will turn off the display of shells.

9. On the **Design** menu choose **Start Design/Check of Structure**. The design check of the structure proceeds.

10. When the design is complete, the member stress ratios are displayed on the structure as shown in Figure C-19. Note that many of the beam stress ratios are quite high. This has occurred because by default SAP2000 assumes that the beams are unsupported for their full length. For simplicity we will assume that the unsupported length for all beams is two feet, except for the roof beam at the braced frame where it is one foot. This makes an unbraced length ratio of 0.0833 for all beams. We will make this change and rerun the design.

    **Note:** The assumption that the unsupported length for all beams is 2 feet may not be realistic in a real building.

![Figure C-19: Initial Member Stress Ratios](image-url)
11. From the Select menu select Select and then Groups… from the submenu. This will display the Select Groups dialog box.

12. Click on the group name ROOF once to highlight it, then, holding down the Ctrl key, click on the group named 2ND to add it to the selection. Click the OK button.


14. In this dialog box:
   - In the Assignment Options area check the box labeled Unbraced Length Ratio (Minor, LTB) and then type 0.0833 in the Unbraced Length Ratio (Minor, LTB) edit box.
   - Click the OK button to close the Preferences dialog box.


16. When the design is complete, the member stress ratios are displayed on the structure as shown in Figure C-20.

![Figure C-20: Final Member Stress Ratios](image_url)
17. Right click on any member to bring up the Steel Stress Check Information dialog box for that member. This dialog box shows details of the interaction ratio for each design load combination at each design station along the element.

18. To get additional detail on any item in this dialog box, highlight the item and click the Details button. A detailed form with design information, similar to that shown in Figure C-21 will appear. Note you can print this form by clicking the associated File menu and selecting Print. Click the “X” in the upper right-hand corner of this detailed form to close it.

*Note: If this form is too big to fully fit on your screen, you may have to increase your screen resolution. Typically, it should fit if your resolution is 800 x 600 and you use small fonts or 1024 x 768 and you use large fonts.*

19. Clicking on the Redesign button will take you to the Element Overwrite Assignments dialog box discussed in item 13.

20. Click the OK button to close the Steel Stress Check Information dialog box.
21. Now we will confirm the unbraced length ratios that were used. From the **Design** menu, select **Display Design Info…** to display the Display Design Results dialog box.

22. In this dialog box:
   - Select the Design Input option.
   - In the design input drop-down box select Unbraced L_ratios.
   - Click the **OK** button to display the unsupported length ratios. They are displayed as Major Unbraced Length Ratio, Minor Unbraced Length Ratio.

23. If you wanted to print a picture of the model with the unbraced length ratios displayed you could do so by selecting **Print Graphics** from the **File** menu now.

24. If you wanted to print design information to the printer, or to a file, you could do so by selecting **Print Design Tables…** from the **File** menu and completing the resulting dialog box. Note that if you select members prior to entering this dialog box, you have the option of printing output for the selected members only.

25. Click the **Show Undeformed Shape** button to clear the display of unsupported length ratios.

26. Click the **Set Elements** button on the main toolbar (or select **Set Elements…** from the **View** menu). This displays the Set Elements Dialog box.

27. In this dialog box uncheck the Hide box in the Shells area and click the **OK** button. This will turn the display of shells back on.

The completes the review of performing a steel design stress check. This also completes Part 1 of this tutorial.
D. Tutorial Part 2 – Pushover Analysis

This portion of the tutorial explores the pushover analysis capabilities of SAP2000. It is assumed that you have basic knowledge of the pushover concept, and that you are familiar with the ATC-40 and FEMA-273 documents.

If you did not complete part C of the tutorial, and thus create the basic model, then you should open the file named Sapwb01c.sdb that was supplied with this tutorial. Note that in a typical analysis you should have, at the very least, run and reviewed the results of a static analysis to verify the behavior of your model prior to running a pushover analysis.

SAP2000 has extensive online help for the pushover analysis. Press F1 from within a pushover related dialog box to get context sensitive help related to the dialog box. To see all of the help items related to pushover analysis, select Search For Help On... from the Help menu, select the Index Tab, highlight the Pushover index entry and click the Display button.

Step 1: Defining Hinge Properties (Pushover)

In this tutorial we will use the default hinge properties, so it is not necessary to define any new properties. In this step we will review the process of viewing already defined hinge properties, and will discuss the process of defining new hinge properties. This step can be skipped if you do not want to review the hinge properties.

Background: There are three types of hinge properties in SAP2000. They are default hinge properties, user-defined hinge properties and generated hinge properties. Only default hinge properties and user-defined hinge properties can be assigned to frame elements. When these hinge properties are assigned to a frame element, the program automatically creates a different generated hinge property for each and every hinge.

Default hinge properties can not be modified. They also can not be viewed because the default properties are section dependent. The default properties can not be fully defined by the program until the section that they apply to is identified. Thus to see the effect of the default properties, the default property should be assigned to a frame element, and then the resulting generated hinge property should be viewed. The built-in default hinge properties are typically based on FEMA-273 and/or ATC-40 criteria.

User-defined hinge properties can be either be based on default properties or they can be fully user-defined. When user-defined properties are based on default properties, the hinge properties can not be viewed because, again, the default properties are section dependent. When user-defined properties are not based on default properties, then the properties can be viewed and modified.

The generated hinge properties are used in the analysis. They can be viewed, but they can not be modified. Generated hinge properties have an automatic naming convention of LabelH#, where Label is the frame element label, H stands for hinge,
and # represents the hinge number. The program starts with hinge number 1 and increments the hinge number by one for each consecutive hinge applied to the frame element. For example if a frame element label is F23, the generated hinge property name for the second hinge applied to the frame element is F23H2.

The main reason for the differentiation between defined properties (in this context, defined means both default and user-defined) and generated properties is that typically the hinge properties are section dependent. Thus it would be necessary to define a different set of hinge properties for each different frame section type in the model. This could potentially mean that a very large number of hinge properties would need to be defined by the user. To simplify this process, the concept of default properties is used in SAP2000. When default properties are used, the program combines its built-in default criteria with the defined section properties for each element to generate the final hinge properties. The net effect of this is that you do significantly less work defining the hinge properties because you don’t have to define each and every hinge.

1. From the Define menu choose Hinge Properties…. This will display the Define Frame Hinge Properties dialog box.

2. Note there are four default hinge properties defined. They are Default-M3, Default-P, Default-PMM, and Default-V2. Highlight the Default-M3 property. Note that the Modify/Show Property button is inactive because you can not view or modify default hinge properties.

3. Check the Show Generated Props check box. If there were generated hinge properties they would now appear in the Defined Hinge props list box. However, since we haven’t yet assigned any hinge properties, the program hasn’t generated any, and thus none appear in the list box.

4. Highlight the Default-V2 hinge property and click on the Define New Property button. The Frame Hinge Property Data dialog box appears.

   Note: When you highlight a property in the Defined Hinge Props area of the Define Frame Hinge Properties dialog box, and then click the Define New Property button, the new property will default to being the same as the highlighted property.

5. Note that the Hinge Type is Shear V2, and that the associated Default check box is checked.

6. Type USER in the Property Name edit box.

7. Click on the Default check box to uncheck it, and then click the Modify/Show For V2 button. This displays the Frame Hinge Property Data For USER dialog box.

8. In this dialog box:
In the Force-Displacement spreadsheet and diagram area:

- Note that the symmetric check box is checked and that the hinge property force-displacement diagram is symmetric. In the diagram, the axes are shown in red. The horizontal axis is displacement and the vertical axis is force.

Note: When the symmetric check box is checked, the upper portion (points B-, C-, D- and E-) of the input spreadsheet for the hinge force-displacement properties is gray. You can not edit these values; they are automatically picked up from symmetry with points B, C, D and E.

- Change the Force/Yield value for point C from 1.25 to 1.5 by typing 1.5 into the appropriate spreadsheet cell and then clicking in any other spreadsheet cell.

- Note the change in shape of the force-displacement diagram. The diagram is scaled to fit within the plot area.

- Note that the Force/Yield value for point C- has changed also from -1.25 to -1.5.

- Uncheck the symmetric check box by clicking it. Note that points B- through E- are no longer gray. Also note that in the Acceptance Criteria area, the Negative column is no longer gray.

- Change the Force/Yield value for point C- from -1.5 to -2 and click in another spreadsheet cell. Again note the change in shape of the force-displacement diagram.

In the Scaling area note that the Calculate Yield Force and Calculate Yield Displacement check boxes are checked by default. This means that the program will automatically calculate these values. We could, for example, overwrite the yield force by unchecking the Calculate Yield Force check box and typing in an appropriate value in the Yield Moment edit box. For this tutorial we will accept the default and have the program calculate the yield values.

- In the Acceptance Criteria area we will also accept the default values. Note that since the Symmetric box is not checked both Positive and Negative values are input. If the Symmetric box was checked, only Positive values would be input (the Negative column would be gray and inactive).

Note: The acceptance criteria are input as the ratio of displacement over yield displacement, similar to the force-displacement spreadsheet.
• In the Type area select the Force-Displacement option. This controls whether the data in the spreadsheet and the acceptance criteria are interpreted by the program as force-displacement or stress-strain. The stress-strain option is only available for axial and shear hinges (uncoupled).

Note: When the Type option is set to stress-strain, a hinge length must be input. The hinge length can be input as an absolute length or a relative length. The relative length is relative to the clear length of the frame element between rigid end offsets. If the stress-strain option is chosen, the program internally transforms the data into a force-displacement format for analysis. The force is calculated as the stress times the frame member axial area (σA) for axial hinges and the stress times the frame member shear area (σAV) for shear hinges. The displacement is calculated as the strain times the hinge length (εL).

• Click the OK button three times to accept the USER hinge property definition.

• We will now delete the USER hinge property since we are not going to use it.

• From the Define menu choose Hinge Properties…. This will display the Define Frame Hinge Properties dialog box.

• Highlight the USER hinge property and click on the Delete Property button. Click the Yes button when the program asks if it is OK to delete Frame Hinge USER from list.

• Click the OK button to accept the change in hinge properties and exit the Define Frame Hinge Properties dialog box.

Note: If you click the Cancel button the property will not be deleted.

This completes the review of defining hinge properties.
Step 2: Assigning Hinge Properties (Pushover)

We will assign Default-PMM hinges to each end of the moment frame columns and the braced frame columns. We will assign Default-M3 hinges to each end of the moment frame beams. We will assign Default-P to the center of each brace.

1. Click in the window labeled 3-D View to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. From the Select menu choose Select, and then Groups… from the submenu. This will display the Select Groups dialog box.

3. Highlight the group named FRCOLS by clicking on it.

4. Hold down the CTRL key and highlight the group named BRCOLS by clicking on it to add it to the selection.

5. Click the OK button to select all of the elements in the FRCOLS and BRCOLS groups.

6. From the Assign menu choose Frame, and then Hinges (Pushover)... from the submenu. This will display the Frame Hinges (Pushover) dialog box.

7. In this dialog box:

- Select Default-PMM in the Hinge Property drop-down box.

- Type 0 in the Relative Distance edit box.

Note: Relative distance is measured from the I-end of the beam, and is based on the clear length between rigid end offsets. A “0” relative distance indicates the hinge is at the I-end of the beam. A “1” relative distance indicates the hinge is at the j-end of the beam. Hinges may be located anywhere along the length of the beam.

- Click the Add button to add a PMM hinge at the I-end (relative distance equals 0) end of the beam.
• Type 1 in the Relative Distance edit box.

• Click the Add button to add a PMM hinge at the J-end (relative distance equals 1) end of the beam.

• Click the OK button to assign the hinge properties. The model now appears as shown in Figure D-1.

![Figure D-1: Model After Assigning Default-PMM Hinges To Columns](image)

Note: Generated hinge properties have an automatic naming convention of LabelH#, where Label is the frame element label, H stands for hinge, and # represents the hinge number. The program starts with hinge number 1 and increments the hinge number by one for each consecutive hinge applied to the frame element. For example if a frame element label is F23, the generated hinge property name for the second hinge applied to the frame element is F23H2. These are the numbers shown on the screen. The item in parenthesis next to the hinge number is the defined hinge that the generated properties are based on. On the screen the Default-P, Default-V2, Default-V3, and Default-PMM are shortened to P, V2, V3 and PMM.

8. From the Select menu choose Select, and then Groups... from the submenu. This will display the Select Groups dialog box.

9. Highlight the group named FRMGIRD by clicking on it and click the OK button.
10. From the **Assign** menu choose **Frame**, and then **Hinges (Pushover)**… from the submenu. This will display the Frame Hinges (Pushover) dialog box.

11. In this dialog box:

   - Select Default-M3 in the Hinge Property drop-down box.
   - Type 0 in the Relative Distance edit box.
   - Click the **Add** button.
   - Type 1 in the Relative Distance edit box.
   - Click the **Add** button.
   - Click the **OK** button to assign the hinge properties.

12. From the **Select** menu choose **Select**, and then **Groups**… from the submenu. This will display the Select Groups dialog box.

13. Highlight the group named BRACE1 by clicking on it.

14. Hold down theCTRLkey and highlight the group named BRACE2 by clicking on it to add it to the selection.

15. Click the **OK** button to select all of the elements in the BRACE1 and BRACE2 groups.

16. From the **Assign** menu choose **Frame**, and then **Hinges (Pushover)**… from the submenu. This will display the Frame Hinges (Pushover) dialog box.

17. In this dialog box:

   - Select Default-P in the Hinge Property drop-down box.
   - Type .5 in the Relative Distance edit box.
   - Click the **Add** button to add a P hinge at the center (relative distance equals 0.5) of the beam.
   - Click the **OK** button to assign the hinge properties.

18. From the **Assign** menu select **Clear Display of Assigns** to clear the display of hinge assignments.
19. Click the **Save Model** button on the main toolbar, or select **Save** from the **File** menu to save the file.

This completes the assigning of pushover hinge properties.
Step 3: Viewing Generated Hinge Properties (Pushover)

This section will demonstrate the process to view generated hinge properties. This step can be skipped if you do not want to view generated hinge properties.

1. Click in the window labeled 3-D View to make sure it is active. Note when the window is active, its title bar will be highlighted.

2. Click the Set Elements button on the main toolbar (or select Set Elements… from the View menu). This displays the Set Elements Dialog box.

3. In this dialog box check the Rel / Hinge box in the Frames area and click the OK button. This will turn the display of hinges on.

4. Note that the hinge at the top of column element 1 is labeled 1H2. (Column element 1 is a lower level column located at X=-24 ft, Y=-24 ft.) We will view the properties for this PMM hinge.

   Note: In the hinge label 1H2, the 1 indicates the hinge is applied to frame element 1, the H indicates it is a pushover hinge, and the 2 indicates it is the second hinge applied to that frame element. This is an automatic naming convention used by the program for generated hinges.

5. From the Define menu choose Hinge Properties…. This will display the Define Frame Hinge Properties dialog box.

6. Check the Show Generated Props check box. The generated hinge properties now appear in the Defined Hinge props list box.

7. In the All Hinge Props area, click on the hinge labeled 1H2 to highlight it and then click the Modify/Show Property button. This will display the Frame Hinge Property Data dialog box.

8. Note that since this is a default PMM hinge, the P-M2-M3 box is checked, but it is gray and inactive. The program also automatically checks the Axial P, Moment M2 and Moment M3 boxes. All of these boxes are gray and inactive since the user can only view generated hinge properties not change them.

9. Click the Modify/Show For PMM button to display the Frame Hinge Property Data For 1H2 dialog box (see Figure D-2).

10. In this dialog box:

   - You can not edit any of the values because this is a generated hinge.
   - The spreadsheet is filled with $M/M_Y$ and $\theta/\theta_Y$ values.
The default hinge properties are symmetric.

In the scaling area the Yield Rotation is filled in and the Yield Moment is gray and inactive. The Yield Rotation was calculated by the program based on the associated frame section property. The Yield Moment is inactive because this is a PMM hinge and there is no single yield moment, there is a yield (interaction) surface instead. If this were just a moment hinge then there would be a value in the Yield Moment box.

The acceptance criteria are $\theta/\theta_Y$ values.

Click the **Define/Show Interaction** button to display the Frame Hinge Interaction Surface dialog box. In this dialog box which is mostly inactive because you are viewing a generated hinge property, note:

- The User Definition option is used.
- The Doubly Symmetric About M2 and M3 check box is checked.
- Five curves are used to define the interaction surface.
Note: The Number of Curves edit box indicates the number of equally spaced P-M curves that will be used to define the interaction surface. If the Doubly Symmetric About M2 and M3 box is checked, then the curves are equally spaced between 0 and 90 degrees. If the Doubly Symmetric About M2 and M3 box is not checked, then the curves are equally spaced between 0 and 360 degrees.

Click the Define/Show Surface button to display the Interaction Surface Definition dialog box.

In this dialog box:

- The spreadsheet shows normalized values of axial load, P, and moment, M. There is one P column and five M columns corresponding to the number entered in the Number of Curves edit box in the previous dialog box. Use the scroll bars to see the other M columns.

Note: The axial load is normalized by the maximum axial load value. The moments are normalized by the maximum moment value for all of the moment curves. Thus the maximum value in the spreadsheet for both axial load and moment is 1.

- The diagram shows the P versus M curves. Click in an M column in the spreadsheet to see that particular P versus M curve. The M curve at Angle 0 corresponds to +M2 bending. The M curve at Angle 90 corresponds to +M3 bending.

- In the scaling area, the scale factors for both axial load, P, and moment, M, are shown. Note that the M scale factor applies to all of the M curves.

Note: Since both P and M are normalized to 1, the P and M scale factors are the maximum values of P and M, respectively.

11. Click the Cancel button five (5) times to exit all of the Hinge Property dialog boxes.
12. Click the **Set Elements** button on the main toolbar (or select **Set Elements**… from the **View** menu) to display the Set Elements Dialog box. In this dialog box uncheck the Rel / Hinge box in the Frames area and click the **OK** button to turn off the display of hinges.

This completes the viewing of generated hinge properties.
**Step 4: Defining Static Pushover Cases**

For this tutorial example we will define six static pushover cases. The first will apply the gravity load to the structure, and the other five will apply different distributions of lateral load to the structure.

1. From the **Define** menu choose **Static Pushover Cases**. This will display the Define Static Pushover Cases dialog box.

2. Click the **Add New Pushover** button to display the Static Pushover Case Data dialog box.

3. In this dialog box:
   - Type GRAV in the Pushover Case Name edit box.
   - In the Options Area select the Push To Load Level Defined By Pattern option button.  

   *Note: Typically the Push To Load Level Defined By Pattern option is used to apply gravity load, and the Push To Displacement Of option is used to apply lateral pushes.*

   - In the Load Pattern do the following:
     - Select DL from the Load drop-down box.
     - Type 1 in the Scale Factor edit box.
     - Click the **Add** button.
     - Select LL from the Load drop-down box.
     - Type 0.25 in the Scale Factor edit box.
     - Click the **Add** button.
   - Accept all of the other default values. Note that the default Control Joint, joint 19, occurs at the roof. The dialog box appears as shown in Figure D-3.
   - Click the **OK** button to complete this pushover case definition.

*Note: There are five control parameters in the right-hand side of the Options area. These parameters are used to control the pushover analysis. For most analyses the default values are sufficient.*

*The Minimum Saved Steps and Maximum Saved Steps provide control over the number of points actually saved in the pushover analysis. The default values are*
adequate in most cases. If the minimum number of steps saved is too small, you may not have enough points to adequately represent the pushover curve. If the minimum and maximum number of saved steps is too large, then the analysis may consume a considerable amount of disk space, and it may take an excessive amount of time to display results.

The program automatically determines the spacing of pushover steps to be saved as follows. The maximum step length is equal to total force goal or total displacement goal divided by the specified Minimum Saved Steps. The program starts by saving steps at this increment. If a significant event occurs at a step length less than this increment, then the program will save the step too and pick up with the maximum increment from there. For example, suppose the Minimum Saved Steps and Maximum Saved Steps are set at 20 and 30 respectively, and the pushover is to be to a displacement of 10 inches. The maximum increment of saved steps will be 10 / 20 = 0.5 inches. Thus, data is saved at 0.5, 1, 1.5, 2, 2.5 inches. Suppose that a significant event occurs at 2.7 inches. Then data is also saved at 2.7 inches, and continues on from there being saved at 3.2, 3.7, 4.2, 4.7, 5.2, 5.7, 6.2, 6.7, 7.2, 7.7, 8.2, 8.7, 9.2, 9.7 and 10.0 inches.
The Maximum Saved Steps controls the number of significant events for which data will be saved. The program will always reach the force or displacement goal within the specified number of maximum saved steps, however, in doing so it could have to skip saving steps at later events. For example, suppose the Minimum Saved Steps is set to 20, the Maximum Saved Steps is set to 21, and the pushover is to be to a displacement of 10 inches. The maximum increment of saved steps will be $10 / 20 = 0.5$ inches. Thus, data is saved at 0.5, 1, 1.5, 2, 2.5 inches. Suppose that a significant event occurs at 2.7 inches. Then data is also saved at 2.7 inches, and continues on from there being saved at 3.2 and 3.7 inches. Suppose another significant event occurs at 3.9 inches. The program will not save the data at 3.9 inches because if it did it would not be able to limit the maximum increment to 0.5 inches and still get through the full pushover in no more than 21 steps. Note that if a second significant event occurred at 4.1 inches rather than 3.9 inches, then the program would be able to save the step and still meet the specified criteria for maximum increment and maximum number of steps.

The Maximum Failed Steps is used, if necessary, to declare failure (i.e., non-convergence) in a run before it reaches the specified force or displacement goal. The program may be unable to converge on a step when catastrophic failure occurs in the structure. There may also be instances where it is unable to converge on a step due to numerical sensitivity in the solution. The Maximum Failed Steps is a cumulative counter through the entire analysis. If the Maximum Failed Steps is reached, the analysis stops.

The Event Force Tolerance and the Event Deformation Tolerance are ratios that are used to determine when an event actually occurs for a hinge. Consider the figure that shows the location of two hinges on their force-displacement plots. Hinge 1 has reached an event location. For hinge 2, if both the Event Force Tolerance and the Event Displacement Tolerance are met, then the hinge is within event tolerance and it too will be treated as part of the event. In the figure, if the Force Tolerance divided by the Yield Force is less than the Event Force Tolerance specified in the Static Pushover Case Data, and the Displacement Tolerance divided by the horizontal distance from B to C is less than the Displacement Event Tolerance specified in the Static Pushover Case Data, then hinge 2 will be treated as part of the event. When determining the Force Tolerance Ratio,
the denominator is always the yield force. When determining the Displacement Tolerance Ratio, the denominator is the horizontal length of the portion of the force-displacement curve that the hinge is currently on. In the figure, hinge 2 is on the B-C portion of the curve, thus we used the B-C horizontal length in the denominator of the Displacement Tolerance Ratio.

4. Click the Add New Pushover button to display the Static Pushover Case Data dialog box.

5. In this dialog box:
   
   • Accept the default Pushover Case Name, PUSH2.
   
   • In the Options area, select GRAV from the Start From Previous Pushover drop-down box.
   
   • In the Options area, check the Include P-Delta box if it is not already checked.
   
   • In the Options area, accept the Push to Displacement Of value of 0.96 feet.

   *Note: The Push To Displacement Of value defaults to 0.04 times the Z coordinate of the highest joint in the model. Note that this may lead to very large displacements if the base of the model is not at Z=0. You can change this value, if necessary, by typing a new value in the edit box.*

   • Accept all of the other default values in the Options Area.
   
   • In the Load Pattern do the following:

     ✓ Select PUSHPAT from the Load drop-down box.

     ✓ Type 1 in the Scale Factor edit box.

     ✓ Click the Add button.

   • Click the OK button to complete this pushover case definition.

6. Click the Add New Pushover button to display the Static Pushover Case Data dialog box.

7. In this dialog box:

   • Accept the default Pushover Case Name, PUSH3.

   • In the Options area, select GRAV from the Start From Previous Pushover drop-down box.

   • In the Options area, check the Include P-Delta box if it is not already checked.
• Accept all of the other default values in the Options Area.

• In the Load Pattern do the following:
  ✓ Select acc dir X from the Load drop-down box.
  ✓ Type 1 in the Scale Factor edit box.
  ✓ Click the Add button.

• Click the OK button to complete this pushover case definition.

8. Click the Add New Pushover button to display the Static Pushover Case Data dialog box.

9. In this dialog box:
   • Accept the default Pushover Case Name, PUSH4.
   
   • In the Options Area do the following:
     ✓ Type .5 in the Push To Displacement Of edit box.
     ✓ Select U2 from the Control Direction drop-down box.
     ✓ Select GRAV from the Start From Previous Pushover drop-down box.
     ✓ Accept all of the other default values in the Options Area.
   
   • In the Load Pattern do the following:
     ✓ Select acc dir Y from the Load drop-down box.
     ✓ Type 1 in the Scale Factor edit box.
     ✓ Click the Add button.
   
   • Click the OK button to complete this pushover case definition.

10. Click the Add New Pushover button to display the Static Pushover Case Data dialog box.

11. In this dialog box:
   • Accept the default Pushover Case Name, PUSH5.
• In the Options area, select GRAV from the Start From Previous Pushover drop-down box.

• In the Options area, check the Include P-Delta box.

• Accept all of the other default values in the Options Area.

• In the Load Pattern do the following:
  ✓ Select MODE from the Load drop-down box.
  ✓ Type 1 in the Scale Factor edit box.
  ✓ Click the Add button. The Select Mode Number dialog box appears.
  ✓ Type in 1 for the mode number (corresponding to the first mode in the X-direction), and click the OK button.

• Click the OK button to complete this pushover case definition.

12. Click the Add New Pushover button to display the Static Pushover Case Data dialog box.

13. In this dialog box:
  • Accept the default Pushover Case Name, PUSH6.

  • In the Options area, select GRAV from the Start From Previous Pushover drop-down box.

  • In the Options area, check the Include P-Delta box.

  • Accept all of the other default values in the Options Area.

  • In the Load Pattern do the following:
    ✓ Select acc dir X from the Load drop-down box.
    ✓ Type 1 in the Scale Factor edit box.
    ✓ Click the Add button.
    ✓ Select acc dir Y from the Load drop-down box.
    ✓ Type 1 in the Scale Factor edit box.
    ✓ Click the Add button.
• Click the OK button to complete this pushover case definition.

14. Click the OK button to exit the Define Static pushover Cases dialog box.

15. Click the Save Model button on the main toolbar.

This completes the definition of static pushover cases.
Step 5: Running the Pushover Analysis

1. On the Analyze menu select Run Static Pushover.

   Note: To run a pushover analysis, you must first have pushover hinges and pushover load cases defined, at least a static analysis run, and, if steel members with Auto sections, or concrete members whose reinforcing is to be designed by the program are included, you must have run the design portion of the program.

2. A window is opened in which various phases of analysis are progressively reported. When the analysis is complete the screen will display as shown in Figure D-4.

   Note: Most of the information in the scrolling analysis window is appended to the *.log file that was created when the original analysis was run.

3. Use the scroll bar to review the analysis messages and check for any error or warning messages (there should be none).

   Note: One of the items you will see in the scrolling window is labeled Analysis Complete. As each pushover load case is running you will see the value continually changing. It is a measure of what percent of your force or displacement goal you have reached. When the Analysis Complete reaches 1, you have reached your goal. Note that the analysis may not reach its goal (i.e., an Analysis complete of 1) because the structure catastrophically fails earlier or because of numerical sensitivities.

4. Click the OK button in the Analysis window to close it.

This completes running the pushover analysis.
Step 6: Displaying the Pushover Deformed Shape and the Sequence of Pushover Hinge Formation

1. From the Options menu select Windows and the select One from the submenu. The display changes to one window.

   Note: With this option you can select to have from one to four windows on the screen at the same time. Each of the windows can be showing a completely different view.

2. Click the 3-D View button on the main toolbar to show the default 3-D view.

3. Click the Set Elements button on the main toolbar (or select Set Elements... from the View menu). This displays the Set Elements Dialog box. In this dialog box check the Hide box in the Shells area and click the OK button. This will turn off the display of shell elements.

4. Click the Display Static Deformed Shape button, or from the Display menu select Show Deformed Shape... to display the Deformed Shape dialog box.

5. In this dialog box:
   - Select Push2 Static Push from the Load drop-down box.
   - Select Auto in the Scaling area.
   - Check both the Wire Shadow and the Cubic Curve options in the Options area.
   - Click the OK button.

6. The deformed shape will appear. Note that the title of the window includes the information “Deformed Shape (PUSH2 – Step 0)”. Thus we are currently viewing the deformed shape at the start of the pushover. Since the PUSH2 pushover was started from the GRAV pushover, we are also viewing the deformed shape at the end of the GRAV pushover.

   Note: Recall that the PUSH2 pushover load case is the PUSHPAT static load pattern.

7. Right click on any second level or roof level joint to see the displacement for that joint. The displacements will be very small, as is expected when only the gravity load is applied.

8. Click the Right Arrow button located on the right-hand side of the status bar at the bottom of the screen to view the deformed shape of the next step (Step 1) in the pushover.

   Note: When viewing the pushover deformed shape and sequence of hinge formation, the right and left arrow buttons, located in the status bar at the bottom of the screen, provide an easy way to view the deformed shape for the next (right arrow), or previous (left arrow) pushover step.
9. Note that the title of the window includes the information “Deformed Shape (PUSH2 – Step 1)”, and the building moves slightly in the X-direction. You can again right-click on any joint to see its displacement. You can click the **Left Arrow** button to return to Step 0 of the pushover.

10. Continue clicking the **Right Arrow** button until the first colored hinges appear. The first colored hinges should appear in Step 4, as illustrated in Figure D-5. The color of the hinges indicates the state of the hinge, i.e., where it is along its force displacement curve. The legend for the hinge colors is included at the bottom of the screen. The points B, IO, LS, CP, C, D and E are illustrated in the figure. When hinges first appear, they are at point B on the force-displacement curve.

![Figure D-5: First Pushover Hinge Yielding](image)

---

**Figure D-5: First Pushover Hinge Yielding**
11. Continue clicking the **Right Arrow** button to step through the sequence of hinge formation in the pushover to the last step. Note how the colors of the hinges change as the pushover proceeds.

**Note:** To change the color coding for the hinges, From the Options menu, select Colors, and then select the Output tab. The color-coding for the pushover hinge state is controlled by the colors in the area labeled Contours. There are ten contour colors; these contour colors also are used in displaying stress contours for shell elements. Assume the color in the top box, next to the label “Min”, is designated “Box 1”, and the color in the bottom box, next to the label “Max”, is designated “Box 10”. Then the color coding for pushover hinge states is as defined in the table.

<table>
<thead>
<tr>
<th>Point</th>
<th>Color Box</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Box 2</td>
</tr>
<tr>
<td>IO</td>
<td>Box 3</td>
</tr>
<tr>
<td>LS</td>
<td>Box 4</td>
</tr>
<tr>
<td>CP</td>
<td>Box 5</td>
</tr>
<tr>
<td>C</td>
<td>Box 6</td>
</tr>
<tr>
<td>D</td>
<td>Box 7</td>
</tr>
<tr>
<td>E</td>
<td>Box 8</td>
</tr>
</tbody>
</table>

12. At the last pushover step right click one of the roof level joints to see its displacement. It will be about 0.96 feet which is consistent with the displacement goal for the PUSH2 pushover load case.

13. Click the **Start Animation** button, located in the status bar at the bottom of the SAP2000 window, to animate the deformed shape at the last step. When done viewing the animation, click the **Stop Animation** button.

**Note:** In this instance, the animation is only for the particular load step, not for the entire pushover. The purpose of the animation is to make the behavior at that particular load step more apparent. You can create a video of the entire pushover using the Create Video... option on the File menu, however, this option will not be available in the SAP2000 6.20 Beta version.

14. Click the **Display Static Deformed Shape** button, or from the Display menu select **Show Deformed Shape**... to display the Deformed Shape dialog box.

15. In this dialog box:

- Select Push4 Static Push from the Load drop-down box. Recall this is the uniform acceleration in the Y-direction.

- Click the **OK** button.

16. Click the **Right Arrow** button to step through the entire sequence of hinge formation in the pushover. You will note that through the sequence of steps the deformation reverses directions several times. The reason for this is discussed in the note below.

**Note:** When a hinge reaches point C on its force-displacement curve (see figure below), that hinge must begin to drop load. Within the program, the way load is dropped from a hinge that has reached point C is that the pushover force (base shear) is reduced until the force in that hinge is consistent with the force at point D. As the
force is dropped, all elements unload, and the displacement is reduced. Once the yielded hinge reaches the Point D force level, the pushover force (base shear) is again increased and the displacement begins to increase again. This behavior is apparent when displaying the deformed shapes and force diagrams (moment, shear, etc.) for each step of the pushover, when viewing a video created for the pushover, and when displaying the force-displacement plot of the pushover.

17. Click the Show Undeformed Shape button to clear the display of deformed shape for the pushover.

18. Click the Set Elements button on the main toolbar (or select Set Elements… from the View menu). This displays the Set Elements Dialog box.

19. In this dialog box:

- Uncheck the Shrink Elements box in the options area (if it is checked).

- Click the OK button.

This completes the review of the pushover deformed shape and the sequence of pushover hinge formation. You may want to step through the deformed shapes for the other pushover load cases before proceeding on to the next step.
Step 7: Displaying Frame Element Forces at Each Step of the Pushover

1. Click the Member Force Diagram for Frames button, or from the Display menu select Show Element Forces/Stresses, and then Frames... to display the Member Force Diagram for Frames dialog box.

2. In this dialog box:
   - Select Push2 Static Push from the Load drop-down box. Recall this is the PUSHPAT static load pattern.
   - In the Component area select the Moment 3-3 option.
   - In the Scaling area select the Auto option.
   - Check the Fill Diagram box. Note if the Show Values on Diagram box is checked, you will have to uncheck it before you can check the Fill Diagram box.

   *Note: The frame element forces for each step of the pushover can be displayed either with the filled diagram or with the values shown on the diagram.*

   - Click the OK button. The display appears as shown in Figure D-6.

![Figure D-6: Pushover Forces (M3-3) at Step 0](image)
3. Note that the title of the window includes the information “Moment 3-3 Diagram (PUSH2 – Step 0)”. Thus we are currently viewing the M33 moments at the start of the pushover. Since the PUSH2 pushover was started from the GRAV pushover, we are also viewing the M33 moments at the end of the GRAV pushover.

4. Note you can right click on any frame element for a detailed diagram. When done viewing a detailed diagram, right click on another element to view its detailed diagram, or left click anywhere to finish viewing detailed diagrams.

5. Click the **Right Arrow** button located on the right-hand side of the status bar at the bottom of the screen to view the M-33 diagram at the next step (Step 1) of the pushover.

    *Note: When viewing the pushover forces, the right and left arrow buttons, located in the status bar at the bottom of the screen, provide an easy way to view the forces for the next (right arrow), or previous (left arrow) pushover step.*

6. Continue clicking the **Right Arrow** button to step through the moment diagrams for each step of the pushover. You can right click an element at any step for a detailed diagram.

7. Click the **Show Undeformed Shape** button to clear the display of element forces for the pushover.

This completes the review of the frame element forces at each step of the pushover. You may want to step through the element forces for other force components and for other pushover load cases before proceeding on to the next step.
Step 8: Displaying Pushover and Capacity Spectrum Curves

1. From the Display menu select Show Static Pushover Curve... to display the Pushover Curve dialog box.

   Note: If this dialog box does not fully fit on your screen then you may want to increase the resolution of your screen. The dialog box should fully fit on the screen if your resolution is 800 x 600 with small fonts, or 1024 x 768 with large fonts.

2. If no plot is visible in the plot area, then click the Display button at the bottom of the form.

   Note: If at any time the plot area display is not visible in the Pushover curve dialog box, click the Display button.

3. For practice, press the F1 key on the keyboard to see context sensitive on-line help pertaining to this dialog box.

4. When finished with the online help click the “X” in the upper right-hand corner of the Help window to close it, or choose Exit from the File menu on the Help window.

5. Notice that in the Plot Type area, the Base Shear vs Control Displacement option is selected.

   Note: The base shear that is plotted in the Base Shear vs Control Displacement plot is the resultant base shear. The displacement plotted is the displacement in the control direction (not resultant) at the control joint.

6. The dialog box currently appears as shown in Figure D-7. Note the following:

   • The Demand Spectrum area and the Damping Parameters area are gray and inactive. These areas will become active when the Capacity Spectrum option is chosen in the Plot Type area.

   • There are four boxes just below the plot area. These boxes are the Cursor Location, the Performance Point (V, D), the Performance Point (Sa, Sd), the Performance Point (Teff, ßeff). When the Base Shear vs Control Displacement option is chosen in the Plot Type area, only the Cursor Location box is active. Place the cursor (mouse pointer) anywhere over the plot and the coordinates of the pointer will appear in the Cursor Location box. The Performance Point boxes are only filled in when the Capacity Spectrum option is chosen in the Plot Type area.

   • If we wanted to include some notes with any printed graphic output, we could type those notes in the Additional Notes For printed Output edit box.
7. Suppose we want to change the color of the base shear versus displacement curve from the default green color to blue. To do this click on the green color box in the Plot Type area to open the Color dialog box.

8. In this dialog box:
   
   - Click on one of the blue colored boxes.
   
   - Click the OK button to change the color.
   
   - If necessary, click the Display button to redisplay the plot.

9. To change the curve color back to the default green, click the Reset Default Colors button.

10. Now we will override the axis labels and range. The axis labels and range will appear on the screen and on any graphic output. Click the Override Axis Labels/Range button. The Override Axis Labels and Range dialog box appears.

Figure D-7: Pushover Curve For Pushover Load Case PUSH2
11. In this dialog box:
   • In the Horizontal Range area type 2 in the Max edit box.
   • In the Axis Labels area type **Control Joint Displacement** in the Horizontal edit box.
   • In the Axis Labels area type **Resultant Base Shear** in the Vertical edit box.
   • Click the **OK** button to change the axis labels and range.

12. Now we will reset the default axis labels and range. Click the **Override Axis Labels/Range** button. The Override Axis Labels and Range dialog box appears.

13. In this dialog box:
   • Click the **Reset Defaults** button.
   • Click the **OK** button.

14. Select PUSH3 from the Static Pushover Case drop-down box. The plot changes to that for PUSH3. Recall that PUSH3 is the uniform acceleration in the X-direction.

   **Note:** If at any time you want to check and see the definition of a pushover load case click the **Done** button to close the Pushover Curve dialog box. Then, from the **Define** menu select **Static Pushover Cases...** and when the Define Static Pushover Cases dialog box appears, select the pushover case you are interested in, and click the **Modify/Show Pushover** button.

15. Review the base shear versus control displacement curves for the other pushover load cases.

16 Select PUSH2 from the Static Pushover Case drop-down box.

17. Select the Capacity Spectrum option in the Plot Type area. As shown in Figure D-8, the plot changes and the Demand Spectrum area and the Damping Parameters area are now active.

   **Note:** When the capacity spectrum option is chosen, the pushover curve is displayed in ADRS (Acceleration-Displacement Response Spectrum) format. Refer to ATC-40 for a discussion of this format which is essentially a plot of spectral acceleration versus spectral displacement. In SAP2000, the force-displacement pushover curve is converted to the ADRS format by converting the resultant base shear to a spectral acceleration, $Sa$, and the control displacement in the control direction to a spectral displacement, $Sd$, generally based on equations 8-1 thru 8-4 in ATC-40.
Figure D-8: Capacity spectrum For Pushover Load Case PUSH2

18. In the Demand Spectrum area note the following:

- The Seismic Coefficient Ca and the Seismic Coefficient Cv both default to 0.4. Each of these values can be changed by typing a new value in the appropriate edit box. These values control the shape of the 5% damped spectrum. Refer to ATC-40, Chapter 4, for a discussion of, and appropriate values for, Ca and Cv.

- The Show Family of Demand Spectra check box is checked indicating that the family of demand spectra, with up to four different damping ratios, is shown on the plot. The color box adjacent to the Show Family of Demand Spectra check box is red (by default) indicating that the family of demand spectra is shown in red. You can change the color by clicking on the color box.

- There are four edit boxes labeled Damping Ratios. The numbers entered in these boxes are 0.05, 0.1, 0.15 and 0.2. These are the default damping ratios for the family of demand spectra. You can change any of these values by typing a new value in the appropriate edit box. The damping values do not have to be input in order. If you leave a Damping Ratio box blank, or enter a zero (0), then that curve will not be plotted.
Note: The damping ratios must be between 0 and 1. A value of 5% of critical damping should be entered as 0.05, not 5.

- The Show Single Demand Spectrum (Variable Damping) check box is checked indicating that the single demand spectrum is shown on the plot. The color box adjacent to the Show Family of Demand Spectra check box is yellow (by default) indicating that the single demand spectrum is shown in yellow. You can change the color by clicking on the color box.

Note: The single demand spectrum (variable damping) curve is constructed by doing the following for each point on the ADRS pushover curve:

1. Draw a radial line through the point on the ADRS pushover curve. This is a line of constant period.

2. Calculate the damping associated with the point on the curve based on the area under the curve up to that point.

3. Construct the demand spectrum, plotting it for the same damping level as associated with the point on the pushover curve.

4. The intersection point of the radial line and the associated demand spectrum represents a point on the Single Demand Spectrum (Variable Damping) curve.

This method is similar to the method called Procedure B in Chapter 8 of ATC-40 except it does not make the simplifying assumption that the post yield stiffness remains constant. It is essentially the method referred to as “exact” in the discussion of the method called Procedure C in Chapter 8 of ATC-40.

- The Show Constant period Lines At check box is checked indicating that up to four different constant period lines are shown on the plot. The color box adjacent to the Show Constant period Lines At check box is gray (by default) indicating that the constant period lines are shown in gray. You can change the color by clicking on the color box.
Note: In the ADRS format, lines of constant period show up as straight lines radiating from the origin.

- There are four edit boxes associated with the Show Constant period Lines At check box. The numbers entered in these boxes are 0.5, 1, 1.5 and 2. These are the default periods for the lines of constant period. You can change any of these values by typing a new value in the appropriate edit box. The periods do not have to be input in order. If you leave a Period box blank, or enter a zero (0), then that line will not be plotted.

19. In the Damping Parameters area note the following:

- The Inherent + Additional Damping box defaults to 0.05. This value can be changed by typing a new value in the edit box.

Note: To help you understand what value to input in the Inherent + Additional Damping box, refer to ATC-40 equation 8-8. The $\beta_0$ term in this equation is automatically included by the SAP2000 analysis method. The 5% inherent viscous damping term can be specified in the Inherent/Additional Damping edit box as 0.05. If there is additional viscous damping provided in the structure, perhaps by viscous dampers that are not specifically included in the model, then this damping should also be included in the Inherent/Additional Damping edit box. Thus if the damping inherent in the structure is assumed to be 5% of critical damping, and dampers which provide an additional 7% of critical damping are assumed to be added to the structure (although they are not actually in the model), then the value input in the Inherent/Additional Damping edit box should be 0.12, since $0.05 + 0.07 = 0.12$.

If dampers modeled with NLLink elements are included in the model, then for the pushover analysis, the program treats them as linear elements. Their stiffness is based on the linear effective stiffness (KE) and the damping is based on the linear effective damping coefficient (CE). The program uses the linear effective damping coefficient for the damper, together with the effective period to calculate damping which is internally added to the specified Inherent/Additional Damping term.

- There are four Structural Behavior Type options: A, B, C and User. Structural Behavior type B, which should be currently selected, is the default. Structural Behavior Types A, B and C, which define a kappa (κ) factor that reduces the assumed damping, are taken directly from ATC-40. The User option allows input of other values of kappa (κ).

Note: Refer to ATC-40 Section 8.2.2.1.1 for a discussion of structural behavior types. The structural behavior type is used to specify a kappa (κ) factor (see Figure 8-15 in ATC-40) that modifies (reduces) the calculated area of the hysteresis loops to account for assumed pinching of the loops.
20. The performance point in Sa, Sd coordinates is shown in the Performance Point (Sa, Sd) box below the plot. The units for Sa are always g; the current units for Sd are feet. Note you could also estimate the value of the performance point by holding the mouse pointer over the performance point (intersection of the ADRS pushover curve and the single demand spectrum (variable damping)) and reading the value in the Cursor Location box.

*Note: The location of the mouse pointer is specified in the Cursor Location box as (Horizontal axis location, Vertical Axis location). Thus when looking at the Performance Point using the mouse pointer, you will read (Sd, Sa), which is switched from how it is specified in the Performance Point (Sa, Sd) box.*

21. In the Demand Spectrum area, type .6 into the Seismic Coefficient Cv edit box. Click the mouse somewhere on the pushover curve dialog box outside of the Seismic Coefficient Cv edit box to enter the change. Note how both the plot and the Performance Point information below the plot change. Note that the performance point in Sa, Sd coordinates changes.

22. Type .4 into the Seismic Coefficient Cv edit box. Click the mouse on the plot to enter the change.

23. Uncheck the Show Family of Demand Spectra box. The family of demand spectra are removed from the plot.

24. Check the Show Family of Demand Spectra box to show the family of demand spectra again.

25. In the Damping Ratios edit boxes, type .3 in the last box. Click the mouse on the plot to enter the change. Note that the lowest demand spectra got even lower when we increased the damping ratio from 0.2 to 0.3.

26. Type .2 in the last Damping Ratios edit box and click the mouse on the plot to return the form to its original state.

27. In the Damping Ratios edit boxes, delete the value in the second edit box and click the mouse on the plot to enter the change. Note that only three demand spectra now appear on the plot, one with 5% damping, one with 15% damping and one with 20% damping.

28. Type .1 in the second Damping Ratios edit box and click the mouse on the plot to return the form to its original state.

29. Uncheck the Show Single Demand Spectrum (Variable Damping) box. The single demand spectrum is removed from the plot.

30. Check the Show Single Demand Spectrum (Variable Damping) box to show the single demand spectrum again.

31. Uncheck the Show Constant Period Lines At box. The constant period lines are removed from the plot.
32. Check the Show Constant Period Lines At box to show the period lines again.

33. In the fourth (and last) edit box below the Show Constant Period Lines At check box, type 3. Click the mouse on the plot to enter the change. Note that the last period line became flatter.

34. Type 2 in the fourth edit box below the Show Constant Period Lines At check box and click the mouse on the plot to return the form to its original state.

35. In the Damping Parameters area, type .2 in the Inherent + Additional Damping edit box. Click the mouse on the plot to enter the change. The relative location of the single demand spectrum (variable damping) curve changes and the performance point location changes.

36. Type 0.05 in the Inherent + Additional Damping edit box and click the mouse on the plot to return the form to its original state.

37. In the Damping Parameters area, click the Structural Behavior Type A option and observe the change in the relative location of the single demand spectrum (variable damping) curve and the performance point.

38. Click the Structural Behavior Type C option again observing the change in the relative location of the single demand spectrum (variable damping) curve and the performance point.

39. Click the Structural Behavior Type - User option, and note that the adjacent Modify/Show button becomes available. Click the Modify/Show button to display the Override Structural Behavior Type dialog box.

40. In this dialog box:
   - In the Point 1 area type 20 in the Beta Sub Zero edit box and type .6 in the Kappa Factor edit box.
   - In the Point 2 area type 45 in the Beta Sub Zero edit box and type .6 in the Kappa Factor edit box.
   - Click the OK button and observe the change in the relative location of the single demand spectrum (variable damping) curve and the performance point.

41. Click the Structural Behavior Type B option to return the form to its original state.

42. From the File menu at the top of the Pushover Curve dialog box select Display Tables. A table similar to that shown in Figure D-9 appears.
43. In this table note the following:

- Step identifies the step number in the pushover curve.
- $T_{eff}$ is the effective period at the associated step.
- $\beta_{eff}$ is the effective damping at the associated step.
- $S_d(C)$ and $S_a(C)$ define a point on the ADRS capacity curve for the associated step.
- $S_d(D)$ and $S_a(D)$ define a point on the single demand spectrum (variable damping) curve for the associated step.
- Alpha is the factor used in converting the base shear to spectral acceleration at the associated step.
- $P F^*\phi$ is the factor used in converting the displacement to spectral displacement at the associated step.

- To print this table, click on the File menu at the top of the table and select either **Print Tables**, to print to a printer, or **Print Tables To File...**, to print the table to a file.

44. Click the “X” in the upper right-hand corner of the table to close it.

45. Select the Base Shear vs Control Displacement option in the Plot Type area.
46. From the File menu at the top of the Pushover Curve dialog box select Display Tables. A table similar to that shown in Figure D-10 appears.

<table>
<thead>
<tr>
<th>Step</th>
<th>Displacement</th>
<th>Base Shear</th>
<th>A-B</th>
<th>B-IO</th>
<th>IO-LS</th>
<th>LS-CP</th>
<th>CP-C</th>
<th>C-D</th>
<th>D-E</th>
<th>&gt;E</th>
<th>TOTAL</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>4.0098E-04</td>
<td>0.0000</td>
<td>48</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>2</td>
<td>0.0964</td>
<td>56.7417</td>
<td>48</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>3</td>
<td>0.1444</td>
<td>95.1127</td>
<td>48</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>4</td>
<td>0.1856</td>
<td>109.4811</td>
<td>46</td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>5</td>
<td>0.2336</td>
<td>125.1036</td>
<td>46</td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>6</td>
<td>0.2796</td>
<td>127.1146</td>
<td>44</td>
<td>4</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>7</td>
<td>0.3078</td>
<td>136.0007</td>
<td>44</td>
<td>4</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>8</td>
<td>0.3358</td>
<td>146.3966</td>
<td>44</td>
<td>4</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>9</td>
<td>0.3700</td>
<td>154.9516</td>
<td>42</td>
<td>4</td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>10</td>
<td>0.4148</td>
<td>158.5392</td>
<td>41</td>
<td>5</td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>11</td>
<td>0.4514</td>
<td>158.5750</td>
<td>40</td>
<td>6</td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>12</td>
<td>0.4634</td>
<td>159.4086</td>
<td>40</td>
<td>4</td>
<td>4</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>13</td>
<td>0.5334</td>
<td>160.3621</td>
<td>40</td>
<td>4</td>
<td>4</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>14</td>
<td>0.5554</td>
<td>161.2557</td>
<td>40</td>
<td>4</td>
<td>4</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>15</td>
<td>0.6074</td>
<td>162.1492</td>
<td>40</td>
<td>2</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>16</td>
<td>0.6554</td>
<td>163.0429</td>
<td>40</td>
<td>0</td>
<td>9</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>17</td>
<td>0.7034</td>
<td>163.9364</td>
<td>40</td>
<td>0</td>
<td>8</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>18</td>
<td>0.7514</td>
<td>164.8299</td>
<td>40</td>
<td>0</td>
<td>8</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>19</td>
<td>0.7994</td>
<td>165.7235</td>
<td>40</td>
<td>0</td>
<td>8</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>20</td>
<td>0.8474</td>
<td>166.6170</td>
<td>40</td>
<td>0</td>
<td>8</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
<tr>
<td>21</td>
<td>0.8954</td>
<td>167.5106</td>
<td>40</td>
<td>0</td>
<td>6</td>
<td>2</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>48</td>
</tr>
</tbody>
</table>

47. In this table note the following:

- Step identifies the step number in the pushover curve.
- Displacement and Base Shear define a point on the pushover curve for the associated step.
- A-B, B-IO, IO-LS, LS-CP, CP-C, C-D, D-E, >E all identify the total number of hinges within each of these ranges on their associated force-displacement curves.
- TOTAL is the total number of pushover hinges in the structure.
- To print this table, click on the File menu at the top of the table and select either Print Tables, to print to a printer, or Print Tables To File..., to print the table to a file.

48. You can also print graphic plots of the pushover curve and/or capacity spectrum curve as follows:
• Set up the plot on the screen (either in Base Shear vs Control Displacement, or in Capacity Spectrum format) as you want to print it.

• If you want to change the axis labels or the axis range, click the Override Axis Labels/Range button and make the desired changes.

• If you want to have additional notes printed on the graphics plot, type those notes in the Additional Notes For Printed Output edit box.

• To print the graphics, select **Print Graphics** from the **File** menu at the top of the Pushover Curve dialog box.

*Note: Another technique that can be used is to create a screen plot of the entire dialog box which you can then print from another program such as Paint, Microsoft Word for Windows, or any other program that supports graphics.*

To create the screen plot, press the Alt and Print Screen keys on your keyboard. This will send a copy of the active window to the clipboard. (Note that if you just press the Print Screen key, without the Alt key, you will send a picture of the entire screen to the clipboard.) Open your other program that supports graphics and paste the picture into that program. Usually the command to paste the picture is called **Paste**, and it can be found on a menu called **Edit**. Once you have pasted the picture into a file created in your program that supports graphics, you can print from there.

49. Click the “X” in the upper right-hand corner of the table to close it.

50. Click the **Done** button to close the Pushover Curve dialog box.

This completes the review of displaying the pushover and capacity spectrum curves.
E. Final Comments

This tutorial, together with the SAP2000 online help provides extensive documentation of all of the pushover analysis features available in SAP2000. It is intended that you can use this tutorial as a continuing reference for SAP2000 pushover analyses.

As previously noted, you can obtain context-sensitive online help from within any pushover dialog box by pressing the F1 key while that dialog box is open. The names of each of the basic pushover analysis topics covered in the online help are listed below.

- Nonlinear Static Pushover Analysis
- Define Frame Hinge Properties
- Frame Hinge Property Data
- Frame Hinge Property Data For XXX
- Frame Hinge Interaction Surface
- Interaction Surface Definition
- Define Static Pushover Cases
- Static Pushover Case Data
- Assign Frame Hinges (Pushover)
- Pushover Curve
- Override Axis Labels And Range
- Override Structural Behavior Type

The Nonlinear Static Pushover Analysis topic gives an overview of the SAP2000 pushover analysis capabilities. The other topics provide context-sensitive help for dialog boxes of the same name.

Finally, it is emphasized that the SAP2000 documentation for the pushover is not intended to, and does not, document the pushover analysis method, but rather is intended to document the pushover analysis capabilities of SAP2000. For information regarding the pushover analysis method you should refer to the ATC-40 and FEMA-273 documents which are referenced below.

ATC, 1996
*Seismic Evaluation and Retrofit of Concrete Buildings*, Volume 1, ATC-40 Report, Applied Technology Council, Redwood City, California.

FEMA, 1997